Closed Bug 867251 Opened 7 years ago Closed 7 years ago

ANR: sqlite access on main thread in AllPagesTab$AwesomeBarCursorAdapter.getCount

Categories

(Firefox for Android :: Data Providers, defect)

ARM
Android
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 926574

People

(Reporter: jchen, Unassigned)

Details

(Whiteboard: [ANR])

There have been a few ANR reports involving sqlite access on the main thread in AllPagesTab$AwesomeBarCursorAdapter.getCount. For Fennec 23, this accounts for 17 reports over the last month, or about 3% of total reports. 

Main thread stack:
> ...
> android.database.sqlite.SQLiteCursor.getCount (line 133)
> android.database.CursorWrapper.getCount (line 57)
> android.database.CursorWrapper.getCount (line 57)
> android.widget.CursorAdapter.getCount (line 196)
> org.mozilla.gecko.AllPagesTab$AwesomeBarCursorAdapter.getCount (line 408)
> android.widget.AdapterView$AdapterDataSetObserver.onChanged (line 801)
> android.widget.AbsListView$AdapterDataSetObserver.onChanged (line 5958)
> android.database.DataSetObservable.notifyChanged (line 37)
> android.widget.BaseAdapter.notifyDataSetChanged (line 50)
> android.widget.CursorAdapter$MyDataSetObserver.onChanged (line 467)
> android.database.DataSetObservable.notifyChanged (line 37)
> android.database.AbstractCursor.requery (line 137)
> android.database.sqlite.SQLiteCursor.requery (line 225)
> android.database.CursorWrapper.requery (line 186)
> android.database.CursorWrapper.requery (line 186)
> android.widget.CursorAdapter.onContentChanged (line 443)
> android.widget.CursorAdapter$ChangeObserver.onChange (line 459)
> android.database.ContentObserver.onChange (line 129)
> android.database.ContentObserver$NotificationRunnable.run (line 180)
> android.os.Handler.handleCallback (line 725)
> android.os.Handler.dispatchMessage (line 92)
> android.os.Looper.loop (line 137)
> android.app.ActivityThread.main (line 5041)
> java.lang.reflect.Method.invokeNative
> java.lang.reflect.Method.invoke (line 511)
> com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run (line 793)
> com.android.internal.os.ZygoteInit.main (line 560)
> dalvik.system.NativeStart.main

More reports at http://darchons.github.io/anr-analyzer/?files=7/74/Anr-20130403.jgz,2/28/Anr-20130410.jgz,8/8b/Anr-20130416.jgz,1/10/Anr-20130423.jgz#f:anr-20130405,l:4 (requires intranet login)
Whiteboard: [ANR]
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 926574
You need to log in before you can comment on or make changes to this bug.