Closed Bug 867361 Opened 8 years ago Closed 8 years ago

Intermittent test_peerConnection_bug834153.html,test_peerConnection_bug825703.html | application timed out after 330 seconds with no output | command timed out: 1200 seconds without output, attempting to kill

Categories

(Core :: WebRTC: Signaling, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: RyanVM, Assigned: abr)

Details

(Keywords: intermittent-failure, Whiteboard: [WebRTC][blocking-webrtc-][webrtc-uplift])

https://tbpl.mozilla.org/php/getParsedLog.php?id=22424189&tree=Mozilla-Inbound

Rev3 WINNT 5.1 mozilla-inbound opt test mochitest-3 on 2013-04-30 12:33:06 PDT for push e5eb454afdbf
slave: talos-r3-xp-021

12:48:11     INFO -  0[95f84b0]: [GSM Task|def] dcsm.c:532: SIPCC-DCSM: dcsm_process_event: DCSM 11  :(DCSM_READY:ONHOOK )
12:48:11     INFO -  0[95f8360]: [CCAPP Task|def] ccapi.c:1428: SIPCC-CC_API: 1/7, cc_int_onhook: UI -> GSM: ONHOOK
12:48:11     INFO -  0[95f84b0]: [GSM Task|fsm_sm] sm.c:46: SIPCC-FSM: sm_process_event: DEF 9   : 01FBC360x: sm entry: (IDLE:ONHOOK)
12:48:11     INFO -  0[95f8360]: [CCAPP Task|def] ccapi.c:1430: (1/7) On-hook called from e:/builds/moz2_slave/m-in-w32-000000000000000000000/build/obj-firefox/media/webrtc/signaling/signaling_sipcc/../../../../../media/webrtc/signaling/src/sipcc/core/ccapp/ccprovider.c:642
12:48:11     INFO -  0[95f84b0]: [GSM Task|fsm_sm] fsmdef.c:2206: SIPCC-FSM: default - ignoring.
12:48:11     INFO -  0[95f8360]: [CCAPP Task|def] ccapi.c:1428: SIPCC-CC_API: 1/8, cc_int_onhook: UI -> GSM: ONHOOK
12:48:11     INFO -  0[95f84b0]: [GSM Task|def] sm.c:65: SIPCC-GSM: 1/9, sm_process_event: DEF   :(IDLE:ONHOOK )
12:48:11     INFO -  0[95f8360]: [CCAPP Task|def] ccapi.c:1430: (1/8) On-hook called from e:/builds/moz2_slave/m-in-w32-000000000000000000000/build/obj-firefox/media/webrtc/signaling/signaling_sipcc/../../../../../media/webrtc/signaling/src/sipcc/core/ccapp/ccprovider.c:642
12:48:11     INFO -  0[95f84b0]: [GSM Task|def] dcsm.c:532: SIPCC-DCSM: dcsm_process_event: DCSM 11  :(DCSM_READY:ONHOOK )
12:48:11     INFO -  0[95f84b0]: [GSM Task|def] dcsm.c:532: SIPCC-DCSM: dcsm_process_event: DCSM 11  :(DCSM_READY:ONHOOK )
12:48:11     INFO -  0[95f84b0]: [GSM Task|def] dcsm.c:532: SIPCC-DCSM: dcsm_process_event: DCSM 11  :(DCSM_READY:ONHOOK )
12:48:11     INFO -  0[95f84b0]: [GSM Task|def] dcsm.c:532: SIPCC-DCSM: dcsm_process_event: DCSM 11  :(DCSM_READY:ONHOOK )
12:48:11     INFO -  0[95f84b0]: [GSM Task|def] dcsm.c:532: SIPCC-DCSM: dcsm_process_event: DCSM 11  :(DCSM_READY:ONHOOK )
12:48:11     INFO -  0[95f84b0]: [GSM Task|def] dcsm.c:532: SIPCC-DCSM: dcsm_process_event: DCSM 11  :(DCSM_READY:ONHOOK )
12:48:11     INFO -  0[95f84b0]: [GSM Task|def] dcsm.c:532: SIPCC-DCSM: dcsm_process_event: DCSM 11  :(DCSM_READY:ONHOOK )
12:48:11     INFO -  0[95f84b0]: [GSM Task|def] dcsm.c:532: SIPCC-DCSM: dcsm_process_event: DCSM 11  :(DCSM_READY:ONHOOK )
12:53:41  WARNING -  TEST-UNEXPECTED-FAIL | /tests/dom/media/tests/mochitest/test_peerConnection_bug834153.html | application timed out after 330 seconds with no output
Whiteboard: [webrtc][blocking-webrtc+][qa-] → [webrtc]
Version: unspecified → Trunk
Looks like we hit shutdown and Close()ed the PeerConnections, but then something never finished and it hung.  Adam, anything you can figure out from the log?  Is this a dup?
Maybe a dupe of bug 855400 possibly?
blocking? until we get an analysis from Adam on this bug and bug 855400
Whiteboard: [webrtc] → [WebRTC][blocking-webrtc?]
Assignee: nobody → adam
Flags: needinfo?(adam)
Whiteboard: [WebRTC][blocking-webrtc?] → [WebRTC][blocking-webrtc-][webrtc-uplift]
Comment 4 was not at all this.
https://tbpl.mozilla.org/php/getParsedLog.php?id=23432761&tree=Mozilla-Inbound
Summary: Intermittent test_peerConnection_bug834153.html | application timed out after 330 seconds with no output | command timed out: 1200 seconds without output, attempting to kill → Intermittent test_peerConnection_bug834153.html,test_peerConnection_bug825703.html | application timed out after 330 seconds with no output | command timed out: 1200 seconds without output, attempting to kill
This bug appears to be gone. There's a high probability that it was the same root cause as Bug 855400.

Comment 7 is plainly not this bug. Even though the log is no longer available, I'm pretty comfortable that something running on Ubuntu is unrelated to a Windows-only bug.

So, basically, we saw this once, three months ago, and think it's related to (or possibly a dupe of) another bug that has apparently gone away. I'm going to close it.
Status: NEW → RESOLVED
Closed: 8 years ago
Flags: needinfo?(adam)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.