toLocaleFormat "fake year" hack results in nonsense results

RESOLVED DUPLICATE of bug 818634

Status

()

defect
--
minor
RESOLVED DUPLICATE of bug 818634
6 years ago
2 years ago

People

(Reporter: jruderman, Unassigned)

Tracking

({testcase})

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Internally, |toLocaleFormat| turns the year 123 into 9923 before handing it to the platform |strftime| and then turns all occurrences back.  This hack is web-visible:

> new Date(123, 3, 4).toLocaleFormat("9923")
123
Assignee: general → nobody
toLocaleFormat was removed in bug 818634.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 818634
You need to log in before you can comment on or make changes to this bug.