If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Gap between forward button and favicon after backing out of reader mode

VERIFIED FIXED in Firefox 23

Status

()

Firefox for Android
Theme and Visual Design
VERIFIED FIXED
4 years ago
a year ago

People

(Reporter: kats, Unassigned)

Tracking

({regression})

23 Branch
Firefox 24
All
Android
regression
Points:
---

Firefox Tracking Flags

(firefox23 verified, firefox24 verified, fennec23+)

Details

Attachments

(3 attachments)

Created attachment 744142 [details]
Screenshot

STR:

1. Load a page (e.g. http://staktrace.com/spout/)
2. Click on the reader mode icon
3. Click on the back button (either the Android back button or the fennec back button)

Actual results:

There is a gap between the forward button and the favicon (see attached screenshot from Galaxy Tab).
Bug 866143? (Should be on Nightly as of 04/30)
I was testing on the May 01 nightly, so maybe it's not completely fixed. (Testing on tablet in portrait mode, if that makes a difference).
(In reply to Kartikaya Gupta (email:kats@mozilla.com, away May2-May20) from comment #2)
> I was testing on the May 01 nightly, so maybe it's not completely fixed.
> (Testing on tablet in portrait mode, if that makes a difference).

Works for me on today's Nightly.
I'm definitely still seeing this. I just uninstalled and reinstalled Nightly to start with a fresh profile and it still happens. Note that it doesn't happen on initial page load, only after backing out of reader mode as I described in comment 0.
Actually it looks like it happens any time the forward button is visible.
tracking for 23+?
tracking-fennec: --- → ?
I also see this on tablets
tracking-fennec: ? → 23+

Updated

4 years ago
Duplicate of this bug: 873086
More STR in bug 873086
Created attachment 753837 [details] [diff] [review]
(1/2) Reuse width value on BrowserToolbar's updateForwardButton()
Attachment #753837 - Flags: review?(mark.finkle)
Created attachment 753838 [details] [diff] [review]
(2/2) Fix animation margins for forward button
Attachment #753838 - Flags: review?(mark.finkle)
Attachment #753837 - Flags: review?(mark.finkle) → review+
Attachment #753838 - Flags: review?(mark.finkle) → review+
Pushed:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a8723dda588e
https://hg.mozilla.org/integration/mozilla-inbound/rev/03ad0762a89c
Comment on attachment 753837 [details] [diff] [review]
(1/2) Reuse width value on BrowserToolbar's updateForwardButton()

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 858687
User impact if declined: Large gap between title and back button in the url bar on 10" tablets whenever the forward button gets hidden
Testing completed (on m-c, etc.): Landed in m-c now, no issues.
Risk to taking this patch (and alternatives if risky): Low, simply removes an obsolete resource for large tablets.
String or IDL/UUID changes made by this patch: n/a
Attachment #753837 - Flags: approval-mozilla-aurora?
Comment on attachment 753838 [details] [diff] [review]
(2/2) Fix animation margins for forward button

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 858687
User impact if declined: Large gap between title and back button in the url bar on 10" tablets whenever the forward button gets hidden
Testing completed (on m-c, etc.): Landed in m-c now, no issues.
Risk to taking this patch (and alternatives if risky): Low, simply removes an obsolete resource for large tablets.
String or IDL/UUID changes made by this patch: n/a
Attachment #753838 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/a8723dda588e
https://hg.mozilla.org/mozilla-central/rev/03ad0762a89c
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 24
Attachment #753837 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #753838 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/ba0dc50f80d0
https://hg.mozilla.org/releases/mozilla-aurora/rev/5340d1cf6b6d
status-firefox23: --- → fixed
status-firefox24: --- → fixed
This is still happening for me with current nightly.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Mike Hommey (high latency until June 25) [:glandium] from comment #17)
> This is still happening for me with current nightly.

(Asus Transformer TF101)
I can no longer reproduce the bug. (Sony Xperia 10.1 tablet)
I tried this on a TF201, TF201, and Galaxy Tab 2.0 using Aurora and Nightly (06/03) and couldn't reproduce.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
Verified fixed on:
Build: Firefox for Android 24.0a1( 2013-06-24)
Device: HTC One 
OS: Android 2.3.5
status-firefox24: fixed → verified

Comment 22

4 years ago
Verified fixed on:
Build: Firefox for Android 23.0b4(2013-07-09)
Device: Acer A500
OS: Android 3.2.1
status-firefox23: fixed → verified

Comment 23

4 years ago
As per comment comment #21 and comment #22

> Build: Firefox for Android 24.0a1( 2013-06-24)
> Build: Firefox for Android 23.0b4(2013-07-09)

setting the bug to Verified Fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.