Closed Bug 867640 Opened 9 years ago Closed 8 years ago

Can't post any external links to wiki.mo, blocked by anti-spam & no work around

Categories

(Websites :: wiki.mozilla.org, defect)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: deb, Unassigned)

Details

So we often post external links on the wiki when we're doing research or sharing around design documents and whatnot.  Recently we added spam blocking software that blocked this unless you filled in a captcha, but now the captcha doesn't show up so we can't post these at all.

This is a significant problem in that it is blocking us from getting work done.

I just tested this by trying to post a link to a design prototype, and got this error:

===
The text you wanted to save was blocked by the spam filter. This is probably caused by a link to a blacklisted external site.

The following text is what triggered our spam filter: Array
===

Hopefully we can get this sorted out ASAP.  Thanks!
Can you link us to an example page, and what text/code/stuff you're trying to insert that is failing?
To expand: I am able to add external links without any issues. That means the problem is specific to either the pages you're editing, or the links you're adding. And that error you provided actually doesn't sound like a *link*, per se, but more like a particular word ("Array"), which I cannot find in the spam blacklist. So knowing precisely what change you're trying to make and what page you're trying to make it to will help greatly.

Thanks!
Deb,

That error is from our Spam Blacklist extension, which has been around for a long time, even prior to the wikimo update (which added captcha to external links).

I however recently did a massive dump of the upstream (mediawiki) url blocklist for that though, if a particular url/urls are causing you and your team trouble myself or any wikimo sysop or above can remove the specific ones.

The page for that is: https://wiki.mozilla.org/MediaWiki:Spam-blacklist

Let me and jake know what one(s) are getting blocked.
Flags: needinfo?(deb)
(In reply to Deb Richardson [:dria] from comment #0)
> ===
> The following text is what triggered our spam filter: Array
> ===

Fwiw this sounds like a display bug in the version of Spam Blacklist we have, and *could* indicate a real bug in its config or an incompatability, I'm fairly sure that the url you entered will be in our blaclist though, even though the error message doesn't actually show it.
(In reply to Justin Wood (:Callek) from comment #3)
> The page for that is: https://wiki.mozilla.org/MediaWiki:Spam-blacklist

-- err wrong page: https://wiki.mozilla.org/Spam_blacklist
The link i was trying to paste was to cl.ly , but I'm not sure what lucasr was trying to do. Maybe put a NeedInfo on him as well?
Flags: needinfo?(deb)
Specifically, if you want to test: http://cl.ly/image/2B0T3V0m3Y3r/o
(In reply to Deb Richardson [:dria] from comment #6)
> The link i was trying to paste was to cl.ly , but I'm not sure what lucasr
> was trying to do. Maybe put a NeedInfo on him as well?

Ok, cl.ly is un-blocked. Do note that it will still captcha you though.

https://wiki.mozilla.org/Spam_blacklist?title=Spam_blacklist&action=historysubmit&diff=651196&oldid=641521

lucasr, was that also the domain you were using, or is there another one that is blocked preventing work for you?
Flags: needinfo?(lucasr.at.mozilla)
(In reply to Justin Wood (:Callek) from comment #8)
> (In reply to Deb Richardson [:dria] from comment #6)
> > The link i was trying to paste was to cl.ly , but I'm not sure what lucasr
> > was trying to do. Maybe put a NeedInfo on him as well?
> 
> Ok, cl.ly is un-blocked. Do note that it will still captcha you though.
> 
> https://wiki.mozilla.org/
> Spam_blacklist?title=Spam_blacklist&action=historysubmit&diff=651196&oldid=64
> 1521
> 
> lucasr, was that also the domain you were using, or is there another one
> that is blocked preventing work for you?

It was a one off thing: I tried to post a link to a TheNextWeb post. Not sure it's worth whitelisting it as I don't plan to regularly post similar links on our wiki. Up to you.
Flags: needinfo?(lucasr.at.mozilla)
There seems to be no further action required here so I'll close it.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.