test_gallery_flick and alarm-clock tests fail with "TypeError: unsupported operand type(s) for -: 'str' and 'str'"

RESOLVED WONTFIX

Status

Testing
Marionette
--
critical
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: stephend, Assigned: mdas)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 744205 [details]
testcase

TEST-START test_gallery_flick.py
test_gallery_full_screen_image_flicks (test_gallery_flick.TestGallery) ... ERROR

======================================================================
ERROR: test_gallery_full_screen_image_flicks (test_gallery_flick.TestGallery)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/var/jenkins/workspace/b2g.unagi.gaia.nightly.ui/gaiatest/tests/gallery/test_gallery_flick.py", line 40, in test_gallery_full_screen_image_flicks
    image.flick_to_next_image()
  File "/var/jenkins/workspace/b2g.unagi.gaia.nightly.ui/gaiatest/apps/gallery/regions/fullscreen_image.py", line 33, in flick_to_next_image
    self._flick_to_image('next')
  File "/var/jenkins/workspace/b2g.unagi.gaia.nightly.ui/gaiatest/apps/gallery/regions/fullscreen_image.py", line 43, in _flick_to_image
    800)  # gesture duration
  File "/var/jenkins/workspace/b2g.unagi.gaia.nightly.ui/.env/local/lib/python2.7/site-packages/marionette_client-0.5.27-py2.7.egg/marionette/marionette_touch.py", line 40, in flick
    action.flick(element, x1, y1, x2, y2, duration).perform()
  File "/var/jenkins/workspace/b2g.unagi.gaia.nightly.ui/.env/local/lib/python2.7/site-packages/marionette_client-0.5.27-py2.7.egg/marionette/marionette.py", line 149, in flick
    move_x = time_increment*1.0/duration * (x2 - x1)
TEST-UNEXPECTED-FAIL | test_gallery_flick.py TestGallery.test_gallery_full_screen_image_flicks | TypeError: unsupported operand type(s) for -: 'str' and 'str'
----------------------------------------------------------------------
Ran 1 test in 48.438s
After discussing with stephend, zac and dburns, we will not continue to support percentages as parameters to flick(). https://github.com/mozilla/gaia-ui-tests/issues/771 was created to change flick's use in gaia-ui-tests, and has since been resolved.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.