Closed Bug 867675 Opened 8 years ago Closed 8 years ago

Full Screen control in the customization panel doesn't leave the enabled state once it's entered

Categories

(Firefox :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 24

People

(Reporter: jaws, Assigned: jaws)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:M6])

Attachments

(1 file)

Full Screen control in the customization panel doesn't leave the enabled state once it's entered.

STR:
Use the Fullscreen button in the new menu panel
Press the button to enter fullscreen
In fullscreen, press the button to exit fullscreen
Open the menu panel and see that the button is still in the "open" state.
No longer blocks: 855287
Whiteboard: [Australis:M6]
Assignee: nobody → jaws
Whiteboard: [Australis:M6] → [Australis:M7]
Duplicate of this bug: 873076
Status: NEW → ASSIGNED
It could be better to have two different icons : one to display in full-screen the other in normal mode. The main difference would be the arrows direction.
Attached patch PatchSplinter Review
So our theme code for the panel menu only checks for the presence of the 'checked' attribute. However, this is consistent with how much of our theme code works elsewhere in the front-end.

In the case of entering, then exiting, the checked attribute gained the 'false' value, so the attribute was still present and hence the button still showed the checked state.

We could probably get this fixed on mozilla-central now, since it doesn't depend on the customizable UI parts.
Attachment #754873 - Flags: review?(mconley)
Comment on attachment 754873 [details] [diff] [review]
Patch

Review of attachment 754873 [details] [diff] [review]:
-----------------------------------------------------------------

Good to go!
Attachment #754873 - Flags: review?(mconley) → review+
https://hg.mozilla.org/mozilla-central/rev/3fa2eb75768d
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:M7] → [Australis:M6]
You need to log in before you can comment on or make changes to this bug.