Crash trying to open my Inbox (2728 msgs in inbox)

VERIFIED DUPLICATE of bug 8619

Status

P3
major
VERIFIED DUPLICATE of bug 8619
20 years ago
11 years ago

People

(Reporter: esther, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
Using 19990621 on linux, I decide to use my IMAP work account.  Haven't tried
Win32 or mac yet.   Note: This account has 64 folders, 5 with subfolders.  Inbox
has 2728 msgs, Sent folder has 1070 msgs, another has 671 msgs, the rest have
anywhere between 1 and 367 msgs.

When I first clicked on this account I crashed when I tried to open my Sent
folder, but before it finished loading I clicked on 3 folders.  Talkback
incident 10242688.  I then launched seamonkey again and let my Sent folder load
completely before clicking on other folders, that was OK.

I then opened other folders with under 100 msgs, all OK.

Then I tried my Inbox, crashed when I clicked on folders before it finished
loading.  Then I launched again and clicked on Inbox, left it alone, it never
finishes loading, I crash (talkback incident 10243937).

Not sure if this is because of the amount of msgs in inbox or the content of a
message.  I will try to narrow this down by removing messages using 4.6.

Updated

20 years ago
Hardware: HP → PC

Comment 1

20 years ago
nsParseMailMessageState::FinalizeHeaders()
   nsParseMailMessageState::ParseFolderLine()
   nsParseMailMessageState::ParseAFolderLine()
   nsImapMailFolder::ParseAdoptedHeaderLine()
   ParseAdoptedHeaderLineProxyEvent::HandleEvent()
   nsImapEvent::imap_event_handler()
   libplds3.so + 0x1b3b (0x4039eb3b)
   libplds3.so + 0x1ab4 (0x4039eab4)
   nsEventQueueImpl::ProcessPendingEvents()
   event_processor_callback()
   gdk_io_invoke()
[/builds/ramiro/rpm/BUILD/gtk+/gdk/gdkevents.c, line 870]
   g_io_unix_dispatch()
[/builds/ramiro/rpm/BUILD/glib/giounix.c, line 134]
   g_main_dispatch()
[/builds/ramiro/rpm/BUILD/glib/gmain.c, line 647]
   g_main_iterate()
[/builds/ramiro/rpm/BUILD/glib/gmain.c, line 855]
   g_main_run()
[/builds/ramiro/rpm/BUILD/glib/gmain.c, line 912]
   gtk_main()
[/builds/ramiro/rpm/BUILD/gtk+/gtk/gtkmain.c, line 475]
   nsAppShell::Run()
   nsAppShellService::Run()
   __strtod_internal

Updated

20 years ago
Assignee: phil → bienvenu

Comment 2

20 years ago
Reassign to bienvenu
(Assignee)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 3

20 years ago
please retry with tomorrow's build

*** This bug has been marked as a duplicate of 8619 ***

Updated

20 years ago
QA Contact: lchiang → esther
Target Milestone: M8

Comment 4

20 years ago
esther will try this when she gets back from vacation next week.
(Reporter)

Comment 5

20 years ago
I will try this scenario when we get a good build today 7/7.  I know this was
marked as a duplicate, but I read the duplicate.  It mentions messages with no
Subject.  My messages all had subjects so I want to try this before I verify it.
(Reporter)

Updated

20 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

20 years ago
Using build dated 19990707 on win32 & linux, I don't crash trying to open my
Inbox.  I wil verify as dup and open a new one if I run into this again.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.