Closed Bug 868095 Opened 7 years ago Closed 3 years ago

getUserMedia called on load does not work for multiple iframes

Categories

(Firefox :: Site Permissions, defect)

20 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 861716

People

(Reporter: bora123, Unassigned)

References

Details

(Whiteboard: [getUserMedia][blocking-gum-])

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130409194949

Steps to reproduce:

Two getUserMedia camera capturing from two iframes side by side didnt work. Only one of them picks up the camera. I was only offered one dialog to select a camera. Chrome browser asks two times and correctly displays the camera imagery in both iframes even if I pick the same camera for both.


Actual results:

Two getUserMedia camera capturing from two iframes side by side didnt work. Only one of them picks up the camera. I was only offered one dialog to select a camera.


Expected results:

Browser should ask camera selection for both iframes does not matter which one first. The both iframes having getUserMedia on should be able to pick the camera even if they are allowed for the same one.
Summary: getUserMedia → getUserMedia does not work for multiple iframes, only one is allowed
Component: Untriaged → WebRTC
Product: Firefox → Core
QA Contact: jsmith
Whiteboard: [getUserMedia][blocking-webrtc-]
This test works fine
<html> <body>
<iframe width="50%" src="gum_test.html"></iframe>
<iframe width="50%" src="gum_test.html"></iframe>
</body> </html>

(gum_test.html is from the webrtc-landing page)

If you click each Video button,you get a requester and can answer it.  If I modify gum_test.html to start video on load (add a startVideo() at the bottom of the script), only one frame (normally the second) pops a requester and gets video.

I suspect strongly this is a dup of bug 861716 (though that refers to within the same frame).  It does point out that if the requests are from different iframes, they should not be merged.
Assignee: nobody → dao
Status: UNCONFIRMED → NEW
Depends on: 861716
Ever confirmed: true
Whiteboard: [getUserMedia][blocking-webrtc-] → [getUserMedia][blocking-gum-]
Component: WebRTC → General
Product: Core → Firefox
QA Contact: jsmith
See Also: → 885768
Setting media.navigator.permission.disabled to true is a workaround: the bug disappears.
(In reply to Dan Mosedale (:dmose) from comment #2)
> Setting media.navigator.permission.disabled to true is a workaround: the bug
> disappears.

All the permission requesters are bypassed, so it's not really a workaround - it says "sure, have a camera, what to I care!"
Assignee: dao → nobody
blocking-fx: --- → ?
blocking-fx: ? → ---
Flags: firefox-backlog?
Component: General → WebRTC
Product: Firefox → Core
Flags: firefox-backlog? → firefox-backlog-
Component: WebRTC → Device Permissions
Product: Core → Firefox
Summary: getUserMedia does not work for multiple iframes, only one is allowed → getUserMedia called on load does not work for multiple iframes
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 861716
You need to log in before you can comment on or make changes to this bug.