Closed Bug 868181 Opened 7 years ago Closed 7 years ago

ASSERTION: Invalid layer manager (LAYERS_CLIENT) when loading any page on Android

Categories

(Core :: Graphics: Layers, defect)

All
Android
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla23
Tracking Status
firefox22 --- unaffected
firefox23 --- fixed

People

(Reporter: cpeterson, Assigned: mattwoodrow)

Details

(Keywords: regression)

Attachments

(1 file)

I believe this is a mozilla-central regression from 5/19 or 5/20.

Android's nsWindow::DrawTo() function expects LAYERS_BASIC or LAYERS_OPENGL, but gets LAYERS_CLIENT. So DrawTo() logs errors and then skips mWidgetListener->PaintWindow().


I/Gecko   (16250): Invalid layer manager: BackendType=5
I/Gecko   (16250): ###!!! ASSERTION: Invalid layer manager: 'Error', file /Users/cpeterson/Code/mozilla/central/widget/android/nsWindow.cpp, line 999
I/Gecko   (16250): Invalid layer manager: BackendType=5
I/Gecko   (16250): ###!!! ASSERTION: Invalid layer manager: 'Error', file /Users/cpeterson/Code/mozilla/central/widget/android/nsWindow.cpp, line 999
I/Gecko   (16250): Invalid layer manager: BackendType=5
I/Gecko   (16250): ###!!! ASSERTION: Invalid layer manager: 'Error', file /Users/cpeterson/Code/mozilla/central/widget/android/nsWindow.cpp, line 999
I/Gecko   (16250): Invalid layer manager: BackendType=5
I/Gecko   (16250): ###!!! ASSERTION: Invalid layer manager: 'Error', file /Users/cpeterson/Code/mozilla/central/widget/android/nsWindow.cpp, line 999
Summary: ASSERTION: Invalid layer manager: 'Error' when loading any page on Android → ASSERTION: Invalid layer manager (LAYERS_CLIENT) when loading any page on Android
Missing code, or...?
Flags: needinfo?(nical.bugzilla)
This is a regression from my changes, I'll fix it.
Assignee: nobody → matt.woodrow
Flags: needinfo?(nical.bugzilla)
Attached patch Fix the warningSplinter Review
Attachment #745739 - Flags: review?(roc)
Do we actually need the code paths for painting in-process any more?

Afaik, we only needed those for xul-fennec which isn't supported any more.

If that's true, then we can just assert that we've got LAYERS_CLIENT, and remove the others, as well as the gfxContext* paramters (It looks like we only ever use a dummy surface anyway).
(In reply to Matt Woodrow (:mattwoodrow) from comment #4)
> Do we actually need the code paths for painting in-process any more?
> 
> Afaik, we only needed those for xul-fennec which isn't supported any more.

Yeah, I think we don't.
https://hg.mozilla.org/mozilla-central/rev/a260551434fe
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla23
You need to log in before you can comment on or make changes to this bug.