Generate FHR documents

RESOLVED FIXED in Firefox 23

Status

Firefox Health Report
Client: Android
P1
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: rnewman, Assigned: rnewman)

Tracking

(Blocks: 1 bug)

unspecified
Firefox 24
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox23 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Working on this as I build storage (Bug 858742).
(Assignee)

Updated

5 years ago
Blocks: 828654
(Assignee)

Updated

5 years ago
No longer blocks: 828654
(Assignee)

Updated

5 years ago
Blocks: 868442
(Assignee)

Updated

5 years ago
Priority: -- → P1
(Assignee)

Updated

5 years ago
Blocks: 870946
(Assignee)

Comment 1

5 years ago
Created attachment 751922 [details] [diff] [review]
Proposed patch. v1 (from git)

Like most of the rest, this is in rnewman/storage in Git.
Attachment #751922 - Flags: review?(nalexander)
Comment on attachment 751922 [details] [diff] [review]
Proposed patch. v1 (from git)

Review of attachment 751922 [details] [diff] [review]:
-----------------------------------------------------------------

::: mobile/android/base/background/healthreport/HealthReportGenerator.java
@@ +46,4 @@
>     * The document consists of:
>     *
>     * * Basic metadata: last ping time, current ping time, version.
>     * * A map of environments: 'current' and others named by hash. 'current' is fully specified,

nit: format this is an HTML list.
Attachment #751922 - Flags: review?(nalexander) → review+

Comment 4

5 years ago
https://hg.mozilla.org/mozilla-central/rev/efe8602a121a
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

5 years ago
Comment on attachment 751922 [details] [diff] [review]
Proposed patch. v1 (from git)

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): 
String or IDL/UUID changes made by this patch:

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
  New work.

User impact if declined: 
  No FHR in 23.

Testing completed (on m-c, etc.): 
  Baking on m-c for some time. QA overview written up; waiting for QA to execute. Manual testing and automated unit tests.

Risk to taking this patch (and alternatives if risky): 
  None: new work.

String or IDL/UUID changes made by this patch:
  None.
Attachment #751922 - Flags: approval-mozilla-aurora?
Comment on attachment 751922 [details] [diff] [review]
Proposed patch. v1 (from git)

Approving for uplift as part of the body of work for FHR's first revision on Android.
Attachment #751922 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Updated

5 years ago
status-firefox23: --- → fixed
You need to log in before you can comment on or make changes to this bug.