If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Lazily populate tabs in the network request details pane

RESOLVED FIXED in Firefox 23

Status

()

Firefox
Developer Tools: Netmonitor
P2
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: vporof, Assigned: vporof)

Tracking

unspecified
Firefox 24
Points:
---

Firefox Tracking Flags

(firefox23 fixed)

Details

(Whiteboard: [fixed-in-fx-team])

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Clicking on a network request currently populates all detail tabs at once (headers, cookies, response etc.). This could be slow sometimes (e.g. adding a lot of text to the source editor to display the response). It'd be more useful to be lazy in this case (and save some bandwidth!).
(Assignee)

Updated

4 years ago
Priority: -- → P2
(Assignee)

Comment 1

4 years ago
Created attachment 748682 [details] [diff] [review]
v1
Assignee: nobody → vporof
Status: NEW → ASSIGNED
Attachment #748682 - Flags: review?(dcamp)

Comment 2

4 years ago
Comment on attachment 748682 [details] [diff] [review]
v1

Sorry for the delay
Attachment #748682 - Flags: review?(dcamp) → review+
(Assignee)

Updated

4 years ago
Whiteboard: [land-in-fx-team]
(Assignee)

Comment 3

4 years ago
https://hg.mozilla.org/integration/fx-team/rev/94d8c42bdc63
Whiteboard: [land-in-fx-team] → [fixed-in-fx-team]
(Assignee)

Comment 4

4 years ago
Comment on attachment 748682 [details] [diff] [review]
v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): clicking on request items in the network monitor could be very slow sometimes
User impact if declined: wasted time, anger, depression, general sadness
Testing completed (on m-c, etc.): locally, fx-team, nothing can go wrong
Risk to taking this patch (and alternatives if risky): really, nothing can go wrong, I promise; this patch touches developer tools code for a new tool that's never been used before
String or IDL/UUID changes made by this patch: none
Attachment #748682 - Flags: approval-mozilla-aurora?

Comment 5

4 years ago
Comment on attachment 748682 [details] [diff] [review]
v1

We'll hold you to it :)
Attachment #748682 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 6

4 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/e62afd027870
(Assignee)

Updated

4 years ago
status-firefox23: --- → fixed
(Assignee)

Comment 7

4 years ago
https://hg.mozilla.org/mozilla-central/rev/94d8c42bdc63
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 24
You need to log in before you can comment on or make changes to this bug.