Cursor selection buttons in Swype don't work

UNCONFIRMED
Unassigned

Status

()

Firefox for Android
Keyboards and IME
UNCONFIRMED
5 years ago
a year ago

People

(Reporter: CoJaBo, Unassigned, NeedInfo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
This may not be specific to Swype; other keyboards may also include this feature, but I don't know any specifically.

1. Type some text in a single-line input, e.g., on Google.com in the search box.
2. Drag from Swype button to the symbols button to open the cursor keyboard.
3. Position the cursor, hit the Select Text button, and use the arrow buttons to navigate.

Expected:
Text should select as it does in other apps.

Actual:
Selection is erratic; it seems as if it's toggling the select state on/off on every single keypress while the "Select Text" button is pressed, instead of only when that button is pressed/depressed.



This was originally filed as Bug 706336, "Cursor navigation and selection buttons in Swype don't work", however that was narrowed to fixing only the navigation issues.
Hi CoJaBo, Bug 706336 is "Home and End buttons in Swype don't work". Did that bug not fix this issue? The fix should be in Nightly and Aurora.
(Reporter)

Comment 2

5 years ago
I filed that bug for both the selection and navigation issues, which seemed related; someone renamed the bug, and only the one was ever fixed.
Created attachment 745991 [details]
Screenshot of testcase

Seems to work on my Galaxy Nexus 4.2.1, using Swype 3.26
Is this still an issue?
Flags: needinfo?(CoJaBo-Bugzilla)
You need to log in before you can comment on or make changes to this bug.