If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Tabbing between buttons in a dialog does not change the default behavior

VERIFIED DUPLICATE of bug 63728

Status

SeaMonkey
UI Design
VERIFIED DUPLICATE of bug 63728
17 years ago
9 years ago

People

(Reporter: mkaply, Assigned: Blake Ross)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
When tabbing between buttons on the message box, the focus changes to the other 
button, but the default appearance (black border around the button) does not 
change.

This is inconsistent with Windows and OS/2 at least.

Tabbing should cause the default appearance to move so that pressing enter 
presses the new button.

For instance, when the confirm first comes up, pressing tab and pressing enter 
should press the cancel button. It does not.

Comment 1

17 years ago
See comments inside bug 82502...
(Reporter)

Comment 2

17 years ago
cmanske,

I have to humbly disaggree with your comment in bug 82502.

On Windows, tabbing or moving with the arrow keys between buttons changes the 
focus AND the default button. So Mozilla is behaving incorrectly here.

Try this. Right click on an object on Windows, select Delete to get a message 
box. Use the arrow keys or tab. Notice that the focus rectangle and the default 
rectangle move. (you can check any 4.x dialog to see this) How else do you 
change the default button?

Mozilla should do the same at least on Windows.

Comment 3

17 years ago

*** This bug has been marked as a duplicate of 63728 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

16 years ago
Verified duplicate
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

9 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.