IndexedDB cannot open databases on a network drive

RESOLVED DUPLICATE of bug 879133

Status

()

Core
DOM: IndexedDB
RESOLVED DUPLICATE of bug 879133
5 years ago
2 years ago

People

(Reporter: poppertd, Unassigned)

Tracking

20 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130104151925

Steps to reproduce:

1. Create a XULRunner application that opens an IndexedDB database
2. Configure the application to use a profile on a network drive (e.g. \\server\profile)
3. Attempt to open and use the database


Actual results:

The IDBOpenRequest fails with error UnknownError


Expected results:

The database should have opened
(Reporter)

Comment 1

5 years ago
This scenario succeeds in Mozilla 19.0.2 (and all previous versions with IDB support).  I've tried with the latest nightly build (23.0a1) and got the same UnknownError.  This error occurs on both Windows XP and Windows 7.
(Reporter)

Comment 2

5 years ago
I forgot to mention that when the same network drive is mapped to a drive letter (e.g. X:\profile), and the application is configured to use the mapped drive for it's profile location, the scenario laid out above succeeds as expected.

Comment 3

5 years ago
(In reply to poppertd from comment #1)
> This scenario succeeds in Mozilla 19.0.2 (and all previous versions with IDB
> support).  I've tried with the latest nightly build (23.0a1) and got the
> same UnknownError.  This error occurs on both Windows XP and Windows 7.

So there is a possible regression since Firefox 20. Could you use the tool mozregression (see http://harthur.github.io/mozregression/ for details) and find a regression range.

First Firefox 20 nightlies started in Nov 2012 (mozregression --good=2012-11-01).
You should create a new networked profile to use mozregression, it's advised.
Flags: needinfo?(poppertd)
Keywords: regressionwindow-wanted
(Reporter)

Comment 4

5 years ago
I'll work on using mozregression shortly.  In the meantime, I have some info from a debug enabled build I created this morning.

The specific line that fails is http://mxr.mozilla.org/mozilla-release/source/storage/src/mozStorageConnection.cpp#533 (::sqlite3_open_v2(spec.get(), &mDBConn, mFlags, NULL)) with an error of NS_ERROR_FILE_ACCESS_DENIED (0x80520015).  Working my way up the stack, Mozilla 20 opens the connection to SQLite using mozIStorageService#openDatabaseWithFileURL, while Mozilla 19 uses mozIStorageServiceQuotaManagement::openDatabaseWithVFS.
Flags: needinfo?(poppertd)
Any luck yet to get a Regression Range?
Flags: needinfo?(poppertd)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 879133
(Reporter)

Comment 7

4 years ago
Please see bug 879133 for the regression
Flags: needinfo?(poppertd)
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.