Closed Bug 868681 Opened 7 years ago Closed 6 years ago

Offline apps doorhanger not shown

Categories

(Firefox for Android :: General, defect)

x86
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 23

People

(Reporter: gbrown, Assigned: gbrown)

Details

Attachments

(1 file, 1 obsolete file)

The offline apps doorhanger:

  Allow %S to store data on your device for offline use?

is not shown when offline storage is requested.

Logcat shows:

E/GeckoConsole(24773): [JavaScript Error: "ReferenceError: chromeWin is not defined" {file: "chrome://browser/content/OfflineApps.js" line: 45}]

Looks like a recent regression, from bug 854940.
Attached patch define gChromeWin (obsolete) — Splinter Review
Copied the lazy getter code used in aboutAddons.js -- works for me and allows robocop's (currently disabled) testDoorHanger to succeed.
Attachment #745453 - Flags: review?(mark.finkle)
Comment on attachment 745453 [details] [diff] [review]
define gChromeWin

This was a bad review on my part. OfflineApps is injected into the browser.js scope, so BrowserApp.manifest should work fine without the need for a "chromeWindow".

Try this line:
     let requestor = BrowserApp.manifest ? "'" + BrowserApp.manifest.name + "'" : host;
Attachment #745453 - Flags: review?(mark.finkle) → review-
That's better, and works just as well - thanks!
Attachment #745453 - Attachment is obsolete: true
Attachment #745667 - Flags: review?(mark.finkle)
Attachment #745667 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/61a824c4e122
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 23
Verified fixed on:
-build: Firefox for Android 23.0a1(2013-05-12)
-device: Samsung Galaxy Nexus
-OS: Android 4.1.1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.