in the download dialog "File:" should be "Component". Patch will follow.
Sean: any chance for a checkin or are you busy elsewhere?
Comment on attachment 39318 [details] [diff] [review] patch to make file -> component I don't agree that it should be "Component" because it's not we're not only downloading components. There are many other files that are not components.
Comment on attachment 39319 [details] [diff] [review] patch to also fix "From URL:" to just "URL:" However, although I'm usually hesitant in updating strings/UI without it coming from someone belonging to the UE, UI, or pubs group, changing the "From URL" to just "URL" is okay with me. If you could get this sr='ed, I'd be happy to check this in for you.
String changes have an automatic sr= from brendan as long as the module owner is happy with them. Gerv
moa=dveditz for the URL change. "File" seems better (and shorter) than "Component" to me so let's hold off on that part of the change.
changed only From URL: to URL:
verified on build 2001092103 mozilla