Closed Bug 868827 Opened 10 years ago Closed 10 years ago

pause standalone animated GIFs just like one is able to pause entire movies

Categories

(Core :: Graphics: ImageLib, defect)

22 Branch
x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 560084

People

(Reporter: jidanni, Unassigned)

Details

(Keywords: access)

User Agent: Mozilla/5.0 (X11; Linux i686; rv:22.0) Gecko/20130503 Firefox/22.0 Iceweasel/22.0a2
Build ID: 20130503004014

Steps to reproduce:

Viewed the very interesting
http://cdn.theatlantic.com/static/infocus/nuclear050611/s_n14_00530011.gif
which is a part of http://www.theatlantic.com/infocus/2011/05/when-we-tested-nuclear-bombs/100061/


Actual results:

Tired to pause it to get a better look at that second frame... but... couldn't find the pause button. How could it be that watching movies has a pause button, but not watching humble GIF89's?!


Expected results:

There should be some control button somewhere.
Please do not require the user to install an extension just to pause movies or GIFs once they get started.
Keywords: access
(In reply to jidanni from comment #0)
> There should be some control button somewhere.
Do you mean specifically when viewing standalone GIF images?
Controlling individual GIFs on a normal webpage could get problematic if the page has the same GIF embedded more than once.
Component: Untriaged → ImageLib
Product: Firefox → Core
(In reply to Mardeg from comment #1)
> Do you mean specifically when viewing standalone GIF images?
Yes, that is the least one could ask.
That way there really is no excuse not to "remember the brake pedal"... and no I'm not talking about halting downloading.
(In reply to jidanni from comment #2)
> (In reply to Mardeg from comment #1)
> > Do you mean specifically when viewing standalone GIF images?
> Yes, that is the least one could ask.
Thanks, matching the summary to this.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Summary: pause animated GIFs just like one is able to pause entire movies → pause standalone animated GIFs just like one is able to pause entire movies
Duplicate of bug: 560084
You need to log in before you can comment on or make changes to this bug.