Broken bookmark count in folders

RESOLVED WONTFIX

Status

()

--
major
RESOLVED WONTFIX
6 years ago
3 years ago

People

(Reporter: allonitium, Assigned: mano)

Tracking

({regression})

20 Branch
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130409194949

Steps to reproduce:

1. Select non-empty bookmark folder in library (Shift+Ctrl+B)
2. If there's enough bookmars that the scrollbar is visible move it down, if not - click on the empty space below listed bookmars (inside folder - right pane)/


Actual results:

First bookmark in folder is selected by default as if it was clicked. No bookmark count is displayed as in older FX versions (up to 19)


Expected results:

In older FX versions no bookmark was selected and there was bookmark count displayed at bottom below bookmark list. Currently there's no way to see bookmark count for given folder. Is there any other way?
(Reporter)

Updated

6 years ago
Severity: normal → major
Component: Untriaged → Bookmarks & History
Keywords: regression

Comment 1

6 years ago
STR:

1) Start a new profile
2) Open the Library (Ctrl+Shift+B)
3) Double click on the entry "Bookmarks Menu" (on the middle pane, not the right pane)
4) Doube click on the bookmark folder "Mozilla Firefox"

Result: the folder is open and the 1st bookmark is selected instead of displaying the number of bookmarks in the folder (at the bottom).

Regression range:
good=2013-01-12
bad=2013-01-13
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1761f4a9081c&tochange=23eb44a5636b
Keywords: regressionwindow-wanted

Updated

6 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

6 years ago
Blocks: 827293
Keywords: regressionwindow-wanted

Comment 2

5 years ago
Hello,

Any news on this bug since 5 months, and can we hope for a future correction ?

In Firefox 24, the issue is still present and I'm really missing the count number of total bookmarks in a folder...

Here the only way is to select all the bookmarks (Ctrl A), then the number appear in the bottom : "N elements"

But it makes more steps to get the information, and as said before, if we didn't select any bookmark or even click on an empty area, first row is anyway highlighted and no folder total number is displayed at the bottom.

Is it a regression or a volontary disparition awaiting the future of library (to put in a tab etc... like suppression of save - search bar on the top right) ?

Or does someone know an addon bringing back this feature ?

Thanks in advance. Xavier

Comment 3

5 years ago
CC'ing dev in charge of bug 827293.
Flags: needinfo?(mano)
Assignee: nobody → mano
Flags: needinfo?(mano)

Comment 4

5 years ago
Good Day,

This has been broken since Firefox 19 (approximately), & it is still broken in Firefox 25.....

The Only way to count all my bookmarks is by Selecting ALL the bookmarks.
But selecting all the bookmarks is VERY SLOW as I have more than 13,000 bookmarks (& I get script timeout error messages).

As a result I have been forced to use Firefox ESR 17.x.
But the last in the ESR 17.x series is the current Firefox ESR 17.0.10.... 
..therefore I will have NO way around this problem from the week of December 10, 2013.....

Please PLEASE fix this ASAP.

Thank You Very Much,
Roberta
Sorry but this happens for usability reasons, the right pane has always a selection.
Select ALL is the supported way to get the count (fwiw the count panel was intended to count number of selected items, not folder contents)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.