Last Comment Bug 869002 - DocumentFragment should be constructable
: DocumentFragment should be constructable
Status: RESOLVED FIXED
: dev-doc-complete
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla24
Assigned To: Andrea Marchesini [:baku]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-06 07:22 PDT by Erik Arvidsson
Modified: 2013-08-13 01:46 PDT (History)
7 users (show)
philringnalda: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (4.24 KB, patch)
2013-05-23 03:59 PDT, Andrea Marchesini [:baku]
Ms2ger: review+
Details | Diff | Splinter Review

Description Erik Arvidsson 2013-05-06 07:22:47 PDT
http://dom.spec.whatwg.org/#interface-text

Make DocumentFragment constructable so that one can do "new DocumentFragment" instead of "document.createDocumentFragment()"
Comment 1 Erik Arvidsson 2013-05-06 07:25:23 PDT
http://dom.spec.whatwg.org/#documentfragment
Comment 2 Andrea Marchesini [:baku] 2013-05-23 03:59:13 PDT
Created attachment 753212 [details] [diff] [review]
patch
Comment 4 Phil Ringnalda (:philor) 2013-05-26 22:05:59 PDT
And https://hg.mozilla.org/integration/mozilla-inbound/rev/92393d40a42a because bug 874923.

Note You need to log in before you can comment on or make changes to this bug.