If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Disabled radio group item shouldn't be clickable

RESOLVED FIXED in mozilla1.1alpha

Status

SeaMonkey
MailNews: Account Configuration
RESOLVED FIXED
17 years ago
13 years ago

People

(Reporter: racham, Assigned: Joe Hewitt (gone))

Tracking

Trunk
mozilla1.1alpha
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
In the Copies and Folders UI, Place a Copy checkbox should control the state of 
the pickers associated.

It does broadcast the event and disable radio group items and pickers (menu 
lists). Pickers once dsiabled are not clickable. But I am ble to click on 
disabled radio group items. This is new to me. It worked fine when I tested.

Looking into it.
(Reporter)

Comment 1

17 years ago
Looks bunch of other widgets (text fields, menu lists, check boxes) seem to 
honor the disable attribute and are not allowing any clicking.

There seems to be some basic problem with radio group items. Reassigning the 
bug to Ben.

Here the URL to the place which uses the broadcaster and disables based on the 
checkbox status of element "identity.doFcc".

http://lxr.mozilla.org/seamonkey/source/mailnews/base/prefs/resources/content/am
-copies.xul#61

To reproduce :

1. Open mailnews app
2. Edit->MailNews Account Settings
3. On a POP or IMAP account, select item Copies and Folders
4. Check the right hand side panel and the first item is a check box with 2 
radio items below it.
5. Uncheck the check box.
6. Notice that radio group items and associated menu lists get disabled
7. Click on one of those radio buttons..they accept the click and radio group 
item is selected. That is wrong. We shouldn't allow click event here
8. If you try to click on the menulist, you won't succeed and that should be the 
state for radio item also.
Assignee: racham → ben
(Reporter)

Comment 2

17 years ago
If the fix is simple, we should fix this for rtm.

Adding mailtrack and rtm keywords.
Keywords: mailtrack, rtm

Comment 3

17 years ago
Seeing this also in a printing dialog with PC Linux 2001062921 so this
is not limited to Windows and MailNews.

Tabbing through printing dialog activates disabled radio buttons.
Yup. Bad Radiogroup!
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → mozilla1.0

Comment 5

16 years ago
I've been seeing this while testing pref locking as well.  I believe bug 82639
might be related to this, eddy is this correct?

Comment 6

16 years ago
Correct, and I've applied that patch locally, and verified it does fix the
clickable problem.
-> blake
Assignee: ben → blakeross
Status: ASSIGNED → NEW

Comment 8

16 years ago
Pretty sure this is now fixed.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 9

16 years ago
Reopening.

Trunk build 2001-11-13:WinMe
Trunk build 2001-11-09: Linux RH 7.1

1. Settings:
a.The "Place a copy in" checkbox is selected
b. The "Sent" Folder on radio button is selected (radio button is filled)
c. The "Other" radio button is not selected
2. Uncheck the "Place a copy in" checkbox
3. Notice that radio group items and associated menu lists get disabled
3. Click on the first radio button

Actual Results:  With the mouse held down it appears that the radio button
reacts since the radio button appears dark (not disabled) and a rectangular box
appears around the entire selection. Release the mouse and it appears disabled.

Expected Results: Although I cannot change the status of these radio button,
they should not appear to change at any time.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 10

16 years ago
What skin?

Comment 11

16 years ago
The problem appears using the Modern theme.

Updated

16 years ago
Status: REOPENED → ASSIGNED
Target Milestone: mozilla1.0 → mozilla0.9.9

Comment 12

16 years ago
hewitt is one lucky bastard.
Assignee: blakeross → hewitt
Status: ASSIGNED → NEW
Priority: P3 → --
Target Milestone: mozilla0.9.9 → ---
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0
(Assignee)

Updated

16 years ago
Target Milestone: mozilla1.0 → mozilla1.1

Comment 13

15 years ago
fixed along with bug 112789
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.