Closed Bug 869158 Opened 7 years ago Closed 7 years ago

crash in nsSVGDisplayContainerFrame::IsSVGTransformed

Categories

(Core :: SVG, defect, critical)

23 Branch
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 868904
Tracking Status
firefox22 --- unaffected
firefox23 --- affected

People

(Reporter: scoobidiver, Unassigned)

References

Details

(Keywords: crash, regression, Whiteboard: [native-crash])

Crash Data

It first showed up in 23.0a1/20130506. The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c8e47b184aba&tochange=b109e2dbf03b
It's likely a regression from bug 863994.

Signature 	nsSVGDisplayContainerFrame::IsSVGTransformed(gfxMatrix*, gfxMatrix*) More Reports Search
UUID	9af17a54-53fa-406e-b9ac-10a342130506
Date Processed	2013-05-06 20:14:22
Uptime	3308
Last Crash	55.2 minutes before submission
Install Age	1.6 hours since version was first installed.
Install Time	2013-05-06 18:35:02
Product	Firefox
Version	23.0a1
Build ID	20130506030925
Release Channel	nightly
OS	Windows NT
OS Version	6.1.7601 Service Pack 1
Build Architecture	x86
Build Architecture Info	AuthenticAMD family 15 model 104 stepping 2
Crash Reason	EXCEPTION_STACK_OVERFLOW
Crash Address	0x5307a933
App Notes 	
AdapterVendorID: 0x1002, AdapterDeviceID: 0x791f, AdapterSubsysID: 00000000, AdapterDriverVersion: 8.452.0.0
D3D10 Layers? D3D10 Layers- D3D9 Layers? D3D9 Layers- WebGL? WebGL- 
Processor Notes 	sp-processor07.phx1.mozilla.com_18229:2012; MDSW emitted too many frames, triggering truncation
EMCheckCompatibility	True
Adapter Vendor ID	0x1002
Adapter Device ID	0x791f
Total Virtual Memory	2147352576
Available Virtual Memory	1330479104
System Memory Use Percentage	52
Available Page File	4457811968
Available Physical Memory	1467838464

Frame 	Module 	Signature 	Source
0 	xul.dll 	nsSVGDisplayContainerFrame::IsSVGTransformed 	layout/svg/nsSVGContainerFrame.cpp:177
1 	xul.dll 	nsIFrame::IsTransformed 	layout/generic/nsFrame.cpp:994
2 	xul.dll 	nsSVGOuterSVGFrame::IsSVGTransformed 	layout/svg/nsSVGOuterSVGFrame.h:102
3 	xul.dll 	mozilla::css::CommonElementAnimationData::CanAnimatePropertyOnCompositor 	layout/style/AnimationCommon.cpp:309
4 	xul.dll 	ElementTransitions::CanPerformOnCompositorThread 	layout/style/nsTransitionManager.cpp:181
5 	xul.dll 	HasAnimationOrTransition<ElementTransitions> 	layout/base/nsLayoutUtils.cpp:189
6 	xul.dll 	HasAnimationOrTransition<ElementTransitions> 	layout/base/nsLayoutUtils.cpp:194
7 	xul.dll 	nsLayoutUtils::HasAnimationsForCompositor 	layout/base/nsLayoutUtils.cpp:213
8 	xul.dll 	nsIFrame::IsTransformed 	layout/generic/nsFrame.cpp:994
9 	xul.dll 	nsSVGOuterSVGFrame::IsSVGTransformed 	layout/svg/nsSVGOuterSVGFrame.h:102
10 	xul.dll 	mozilla::css::CommonElementAnimationData::CanAnimatePropertyOnCompositor 	layout/style/AnimationCommon.cpp:309
11 	xul.dll 	xul.dll@0x2d39c0 	
12 	xul.dll 	ElementTransitions::CanPerformOnCompositorThread 	layout/style/nsTransitionManager.cpp:181
13 	xul.dll 	HasAnimationOrTransition<ElementTransitions> 	layout/base/nsLayoutUtils.cpp:189
...

More reports at:
https://crash-stats.mozilla.com/report/list?signature=nsSVGDisplayContainerFrame%3A%3AIsSVGTransformed%28gfxMatrix*%2C+gfxMatrix*%29
Blocks: 863994
More reports also at:
https://crash-stats.mozilla.com/report/list?signature=nsIFrame%3A%3APreserves3DChildren%28%29
Crash Signature: [@ nsSVGDisplayContainerFrame::IsSVGTransformed(gfxMatrix*, gfxMatrix*)] → [@ nsSVGDisplayContainerFrame::IsSVGTransformed(gfxMatrix*, gfxMatrix*)] [@ nsIFrame::Preserves3DChildren() ]
Looks like a dupe of bug 868904 (which has a patch and will be fixed shortly).
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 868904
Crash Signature: [@ nsSVGDisplayContainerFrame::IsSVGTransformed(gfxMatrix*, gfxMatrix*)] [@ nsIFrame::Preserves3DChildren() ] → [@ nsSVGDisplayContainerFrame::IsSVGTransformed(gfxMatrix*, gfxMatrix*)] [@ nsIFrame::Preserves3DChildren() ] [@ mozilla::dom::SVGTransformableElement::GetAnimatedTransformList(unsigned int) ]
OS: Windows 7 → All
Whiteboard: [native-crash]
Crash Signature: [@ nsSVGDisplayContainerFrame::IsSVGTransformed(gfxMatrix*, gfxMatrix*)] [@ nsIFrame::Preserves3DChildren() ] [@ mozilla::dom::SVGTransformableElement::GetAnimatedTransformList(unsigned int) ] → [@ nsSVGDisplayContainerFrame::IsSVGTransformed(gfxMatrix*, gfxMatrix*)] [@ nsIFrame::Preserves3DChildren() ] [@ nsIFrame::Preserves3D() ] [@ mozilla::dom::SVGTransformableElement::GetAnimatedTransformList(unsigned int) ] [@ SearchTable ]
You need to log in before you can comment on or make changes to this bug.