[style editor] Remove unused bar at top of editor

RESOLVED FIXED in Firefox 24

Status

defect
RESOLVED FIXED
6 years ago
Last year

People

(Reporter: harth, Assigned: paul)

Tracking

unspecified
Firefox 24
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed-in-fx-team])

Attachments

(2 attachments)

See the screenshot. There's a completely usused bar to the right of the [New] [Import] buttons and above the editor content. It's wasting many pixels of an already small editor space.
Posted patch patch v0.1Splinter Review
Something like that? What about using this toolbar to show the matched rules (bug 869307)?
Attachment #758524 - Flags: feedback?(fayearthur)
(In reply to Paul Rouget [:paul] from comment #1)
> Created attachment 758524 [details] [diff] [review]
> patch v0.1
> 
> Something like that? What about using this toolbar to show the matched rules
> (bug 869307)?

Yeah, it could be used for that. Something smaller, like the Chrome find-in-page bar would be ideal. But this would work.

This definitely frees up some room, which is awesome. It looks a bit weird, maybe because I'm used the bar now.
Comment on attachment 758524 [details] [diff] [review]
patch v0.1

I like it. Get's rid of the resizer as well (bug 872517)
Attachment #758524 - Flags: feedback?(fayearthur) → feedback+
Assignee: nobody → paul
Comment on attachment 758524 [details] [diff] [review]
patch v0.1

I think it's actually ready for review.
Attachment #758524 - Flags: review?(fayearthur)
Duplicate of this bug: 872517
Attachment #758524 - Flags: review?(fayearthur) → review+
Whiteboard: [land-in-fx-team]
https://hg.mozilla.org/integration/fx-team/rev/8d8330b65f26
Whiteboard: [land-in-fx-team] → [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/8d8330b65f26
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 24
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.