HTML and Images with the same colour are rendered differently

NEW
Unassigned

Status

()

Core
Layout: Images
17 years ago
11 years ago

People

(Reporter: Anand Kumria, Unassigned)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
I have an 8 bit colour display and am using X 4.02; when I go to the
Debian site (www.debian.org) the rounded corners on the rectangle appear
in a different colour even though they are the same.

Edited IRC log:

wildfire == me; Joy == webmaster@debian.org

* wildfire notes the rounded corners on the debian site are a different shade of
red to the red rectangle
<Joy> wildfire: they can't be, your display is wrong
<Joy> wildfire: we used the same hex code to generate the HTML and the PNGs
<wildfire> no, my display is right
<wildfire> they come up a different color
<wildfire> err, colour
* wildfire spits .. damn americans
<wildfire> do you want a screen cap.?
<Joy> wildfire: it's #DF0451 in the HTML... lemme check the Gimp
<wildfire> oh, same with the blue corners btw
<Joy> gimp says it's #df0451
<Joy> wildfire: how many colors does your display have?
<Joy> wildfire: 16, 256, 65K, 16M?
<wildfire> 8 bit
<wildfire> 256
<Joy> wildfire: that's probably the reason. arguably we should have used a
different color from the start, but your software should be using the same
color, too.
(Reporter)

Comment 1

17 years ago
Created attachment 39371 [details]
screen capture of problem with blue and red rectangles and their corner images
Could be a gamma-correction issue.  PNGs are gamma-corrected, while text is not...

Comment 3

17 years ago
wfm may be color set
everything looks correct here, even in 8 bit mode.

must have been fixed at some point, marking WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

17 years ago
No, this still fails for me with build 2001080104.

It isn't a colour set issue because the boxes come up the right colour and
portions of the image also come up correctly.

It may be a gamma related issue but I don't believe that mozilla does that for PNGs.

I've used xmag to zoom in on the problem area and the PNG attached is from
electric eyes (and annoyingly the colours differ between all three: mozilla,
xmag and eeyes. sigh.)

Anand
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 6

17 years ago
Created attachment 45515 [details]
close-up of problem with colour mismatch

Comment 7

17 years ago
*** Bug 97478 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
also reported on Mac
OS: Linux → All
Hardware: PC → All

Comment 9

17 years ago
btw, i see it happening in millions of colors.
Marking NEW based on the dupe.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 11

16 years ago
I read thru these ramblings and don't still don't know why, in theory, the color
space should be rendered with any modification at all.

Rendering of html and css colors, yes that requires gamma consider, etc.
However, the answer is simple [unfortunately] just replicate IE.  90% of the
browsers are IE, so designers pick colors that look good with IE; period.  

As I understand it, PNG is a compression algorithm.  Therefore, the
decompression algorithm should repoduce the orginal, without any modification.  

Al.............

Updated

16 years ago
Target Milestone: --- → Future

Updated

16 years ago
Depends on: 53597
In response to comment 11:  Doing gamma correction according to the spec does
replecate IE for Windows, since Windows is already sRGB so no correction needs
to be done.  It just makes Mozilla on other platforms look more like IE for
Windows.  (I don't like that attitude in general, but it's true in this case.)

Updated

16 years ago
Component: ImageLib → Image: Layout

Updated

11 years ago
Assignee: pavlov → nobody
QA Contact: tpreston → layout.images
You need to log in before you can comment on or make changes to this bug.