Last Comment Bug 869322 - Screen can't read the text in input box
: Screen can't read the text in input box
Status: RESOLVED FIXED
: access
Product: Firefox for Android
Classification: Client Software
Component: Keyboards and IME (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: Firefox 23
Assigned To: Chen Dai
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-06 23:41 PDT by Chen Dai
Modified: 2013-05-09 10:27 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch for bug869322 (596 bytes, patch)
2013-05-08 01:59 PDT, Chen Dai
eitan: review+
Details | Diff | Splinter Review

Description Chen Dai 2013-05-06 23:41:40 PDT
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130329030832

Steps to reproduce:

1. enable google talkback
2. open firefox
3. go to google.com
4. input "aaabbbcccddd" into input box


Actual results:

nothing happened


Expected results:

talkback should read "aaabbbcccddd" after input the text

I download the nightly builds, and I found this version "http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/2013/03/2013-03-16-03-08-54-mozilla-central-android/fennec-22.0a1.multi.android-arm.apk" works fine, but this http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/2013/03/2013-03-16-16-05-54-mozilla-central-android/fennec-22.0a1.multi.android-arm.apk" works bad
Comment 1 Kevin Brosnan [:kbrosnan] 2013-05-07 14:28:56 PDT
cc'ing a couple accessibility team members
Comment 2 Chen Dai 2013-05-07 23:01:48 PDT
I think it is due to bug833164
I update the code to revision 124928, it act properly.
But in revision 124929, it cant read
Comment 3 Chen Dai 2013-05-08 00:21:17 PDT
124929:a4e388a97ff3
124928:80be1feda16c
Comment 4 Chen Dai 2013-05-08 01:59:20 PDT
Created attachment 746832 [details] [diff] [review]
patch for bug869322

This bug is because:
after Bug 833164, accessible events cpp were replaced by code gen of xpcom.
The original textchange event had a funtion isInserted, but in the gen code, isInserted changed to a bool attribute.
In Eventmanager, it still calls isInserted(), so it throw a error
Comment 5 Eitan Isaacson [:eeejay] 2013-05-08 09:55:21 PDT
Comment on attachment 746832 [details] [diff] [review]
patch for bug869322

Review of attachment 746832 [details] [diff] [review]:
-----------------------------------------------------------------

Good catch! I'm assuming you tested this?
Comment 6 Chen Dai 2013-05-08 18:35:15 PDT
yes, I have tested it.
Comment 7 Chen Dai 2013-05-08 18:45:41 PDT
What should I do next?
Comment 8 alexander :surkov 2013-05-08 18:47:06 PDT
add 'checking-needed' keyword to get the patch landed and find another bug ;)
Comment 9 Ryan VanderMeulen [:RyanVM] 2013-05-08 18:59:19 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/ad46747e8ec4

Thanks for the patch! In the next day or so, this patch will be merged on to mozilla-central and will be resolved FIXED at that time. Currently, this fix will appear first in Firefox 23. Eitan, should this be nominated for uplift? Seems like a bad bug with a low-risk fix.

One more request, to make life easier for those checking in on your behalf, please make sure that you have Mercurial configured to generate all the necessary metadata for checkin. Instructions are linked below. Thanks again!
https://developer.mozilla.org/en-US/docs/Mercurial_FAQ#How_can_I_generate_a_patch_for_somebody_else_to_check-in_for_me.3F
Comment 10 Ryan VanderMeulen [:RyanVM] 2013-05-09 10:27:03 PDT
https://hg.mozilla.org/mozilla-central/rev/ad46747e8ec4

Note You need to log in before you can comment on or make changes to this bug.