[System] [Video] [Bluetooth] String message is half-hidden when Share->Bluetooth is selected on a video.

RESOLVED FIXED in 1.1 QE2 (6jun)

Status

P1
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: leo.bugzilla.gaia, Assigned: iliu)

Tracking

unspecified
1.1 QE2 (6jun)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 fixed)

Details

(Whiteboard: [TD-10296][TD-23717])

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
1. Title : [System] [Video] [Bluetooth] String message is half-hidden when Share->Bluetooth is selected on a video.
2. Precondition : Run Video app and select a video. And select Share button.
3. Tester's Action : Rotate device and see the bluetooth confirmation dialog also rotates.
4. Detailed Symptom (ENG.) : The string message is half-hidden in the dialog.
5. Expected : Nothing should be hidden in part.
6.Reproducibility: Y
           1)Frequency Rate : 100%
7. Version: AU_LINUX_GECKO_ICS_STRAWBERRY.01.01.00.019.075, Mozilla build ID: 20130425070204
8.Personal email id:  hanj.kim25@gmail.com
(Reporter)

Comment 1

6 years ago
Created attachment 746279 [details]
screenshot
(Reporter)

Comment 2

6 years ago
The same observation has been seen in gallery app.
(Reporter)

Comment 3

6 years ago
It seems that the manifest.webapp's orientation value is ignored when MozActivity is used.

For example, \apps\bluetooth\manifest.webapp has "orientation": "portrait-primary". However, when its 'share' activity is displayed, the orientation does not stay portrait.
(Reporter)

Comment 4

6 years ago
Hi Alive, 

I'd like to ask for your comment on this. Thanks!
Flags: needinfo?(alive)
Two ways to solve this:
1) Make the dialog scrollable.
2) Lock orientation when inline activity shows.
I think 1) is more suitable.
Flags: needinfo?(alive)
c.c. Ian
Duplicate of this bug: 861413
Assignee: nobody → iliu
(Reporter)

Updated

6 years ago
Whiteboard: [TD-10296]

Updated

6 years ago
Whiteboard: [TD-10296] → [TD-10296][TD-23717]
Target Milestone: --- → 1.1 QE2
blocking-b2g: --- → leo+
(Reporter)

Comment 8

6 years ago
(In reply to Alive Kuo [:alive] from comment #5)
> Two ways to solve this:
> 1) Make the dialog scrollable.
> 2) Lock orientation when inline activity shows.
> I think 1) is more suitable.

It seems this applies to all inline activities and 1) fix is limited to a specific dialog only. How about we do 2) and have it fixed in all inline activities?
Priority: -- → P1
(Reporter)

Comment 9

6 years ago
Created attachment 750190 [details]
Power off option

I believe this is also the same issue. How about we have a general fix, which is 2)?
Attachment #750190 - Flags: feedback?(alive)
They are different things but lock orientation for both is acceptable, to me.
Created attachment 750323 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/9811

Pointer to Github pull-request
Comment on attachment 750323 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/9811

The base font size 13.3px makes the message truncated in landscape mode.
Remove media query for 480x800 phones. We don't support multi-resolution in v1-train.
Attachment #750323 - Flags: review?(alive)
Gaia master contains https://github.com/mozilla-b2g/gaia/commit/6089f2f0a5698e77494881b58b2721d781c887fc for supporting multiple resolution. The issue won't be happened since it removed the based font size 13.3px.
(Reporter)

Comment 14

6 years ago
(In reply to Ian Liu [:ianliu] from comment #13)
> Gaia master contains
> https://github.com/mozilla-b2g/gaia/commit/
> 6089f2f0a5698e77494881b58b2721d781c887fc for supporting multiple resolution.
> The issue won't be happened since it removed the based font size 13.3px.

Hi Ian, 

Your patch fixes only the bluetooth inline activity. Can we have a patch that fixes this issue in general?

This is not just a resolution issue. 

For example, this bluetooth inline activity's manifest.app has "orientation": "portrait-primary". However, it rotates!
(\b2g\gaia\apps\bluetooth\manifest.webapp)
(In reply to Leo from comment #14)
> (In reply to Ian Liu [:ianliu] from comment #13)
> > Gaia master contains
> > https://github.com/mozilla-b2g/gaia/commit/
> > 6089f2f0a5698e77494881b58b2721d781c887fc for supporting multiple resolution.
> > The issue won't be happened since it removed the based font size 13.3px.
> 
> Hi Ian, 
> 
> Your patch fixes only the bluetooth inline activity. Can we have a patch
> that fixes this issue in general?
> 
> This is not just a resolution issue. 
> 
> For example, this bluetooth inline activity's manifest.app has
> "orientation": "portrait-primary". However, it rotates!
> (\b2g\gaia\apps\bluetooth\manifest.webapp)

In my opinion, I don't think it's a friendly way to lock orientation for inline activity page. We should keep current behavior here. If we really want to do so, it should reference the orientation in "activities" scoop. Could be..

  "activities": {
    "share": {
      "filters": {
      	"number": 1
       },
      "disposition": "inline",
      "returnValue": true,
      "href": "/transfer.html",
+     "orientation": "portrait-primary",
    }   
  }, 

And the parameter could be: "portrait-primary", "landscape-primary", "depend-requester"... We should create another issue for the new feature.
(In reply to Leo from comment #14)
> (In reply to Ian Liu [:ianliu] from comment #13)
> > Gaia master contains
> > https://github.com/mozilla-b2g/gaia/commit/
> > 6089f2f0a5698e77494881b58b2721d781c887fc for supporting multiple resolution.
> > The issue won't be happened since it removed the based font size 13.3px.
> 
> Hi Ian, 
> 
> Your patch fixes only the bluetooth inline activity. Can we have a patch
> that fixes this issue in general?
> 
> This is not just a resolution issue. 
> 
> For example, this bluetooth inline activity's manifest.app has
> "orientation": "portrait-primary". However, it rotates!
> (\b2g\gaia\apps\bluetooth\manifest.webapp)

We could open another bug for the orientation hell we have.
Exactly, any app/any activity/any window.opened page could lock orientation..without manifest.
And that may result lots of problems..because currenly it's not manipulated well.
Comment on attachment 750323 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/9811

r+ first since this is QE2 bug...
Attachment #750323 - Flags: review?(alive) → review+
Thanks for Alive's reviewing effort. Since the pr is merged, we can close the issue now.
https://github.com/mozilla-b2g/gaia/commit/991bb2d9a64df2e532ad92677248aec30076ee8b
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Attachment #750190 - Flags: feedback?(alive)
(In reply to Ian Liu [:ianliu] from comment #18)
> Thanks for Alive's reviewing effort. Since the pr is merged, we can close
> the issue now.
> https://github.com/mozilla-b2g/gaia/commit/
> 991bb2d9a64df2e532ad92677248aec30076ee8b

This commit is on v1-train, so marking the branch status appropriately.

Is there anything that needs to be landed on master branch for this?
status-b2g18: --- → fixed
Flags: needinfo?(iliu)
Hi John,
Thanks for your reminder. It doesn't need to be landed on master because the removed code is not in master. It has been removed via supporting multiple resolution for a long time.
Flags: needinfo?(iliu)
You need to log in before you can comment on or make changes to this bug.