Closed Bug 869384 Opened 8 years ago Closed 8 years ago

B2G Network Manager: navigator.onLine starts true even if false

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: zcampbell, Unassigned)

References

Details

+++ This bug was initially created as a clone of Bug #806965 +++

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_2) AppleWebKit/537.4 (KHTML, like Gecko) Chrome/22.0.1229.94 Safari/537.4

Steps to reproduce:

Once the device boots and connection is offline by default


Actual results:

navigator.onLine returns true


Expected results:

navigator.onLine returns false.

Only after connecting and disconnecting does the property return false as expected.
Replicating this today on the following build:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/79f7e6df5751
Gaia   29f5faf992aa2bacf6a9d500494093edd9472c69
BuildID 20130506230205
Version 18.0


Although I know it's a poor regression range but this does not occur on b2g18/v1-train builds.
Priority: P3 → --
Hardware: Other → ARM
I think we're actually seeing bug 840612, no?
I can't tell if they are related but we're definitely seeing this always returning true on b2g18/v1.0.1.
From the description, it sounds like the issue is with the API and will impact apps that detect the device is online when there is no network connection present. Can you confirm? 

Does this issue manifest in the B2G UI as well?
Flags: needinfo?(zcampbell)
This was resolved by the uplift of the patch in bug 840612 into v1.0.1.

Apologies Lawrence for not resolving this bug sooner.
Status: NEW → RESOLVED
Closed: 8 years ago
Flags: needinfo?(zcampbell)
Resolution: --- → FIXED
blocking-b2g: tef? → ---
You need to log in before you can comment on or make changes to this bug.