Closed Bug 869567 Opened 7 years ago Closed 7 years ago

Nightly crashes on inspecting |window| on Facebook page.

Categories

(Core :: XPConnect, defect, critical)

x86_64
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 867771

People

(Reporter: Optimizer, Unassigned)

References

Details

(Keywords: crash)

Crash Data

Not sure which is the right compartment here. I don't think its Dev Tools. Anyhow:

1) Open Facebook and log in to it using the latest Nightly.
2) Leave your username - password in the comments.
3) Open Web Console, type window and press enter in the input area at the bottom.
4) With the Logging filter on, click on the [Object Window] output.
5) Boom, Nightly crashes.
Happens on Gmail also.
mine's here:

https://crash-stats.mozilla.com/report/index/bp-d360da47-afa8-4b34-aa24-6b6c22130507
Crash Signature: js::CompartmentChecker::fail(JSCompartment*, JSCompartment*)
not much needed, but mine is : https://crash-stats.mozilla.com/report/index/bp-766b1a22-34ae-438e-bab8-2937b2130507

this can be probably related to bug 869027
Sounds sort of like a dupe of bug 867771, though the stack isn't quite the same.
Severity: normal → critical
Crash Signature: js::CompartmentChecker::fail(JSCompartment*, JSCompartment*) → [@ js::CompartmentChecker::fail(JSCompartment*, JSCompartment*) ]
Component: Developer Tools → XPConnect
Keywords: crash
Product: Firefox → Core
Can't replicate after a clobber build on Windows 8 (didn't try before the clobber though).
This is almost certainly bug 867771.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 867771
You need to log in before you can comment on or make changes to this bug.