Closed Bug 869706 Opened 7 years ago Closed 7 years ago

BaselineCompiler: Track nonNativeGetElement and accessGetter info in baseline scripts

Categories

(Core :: JavaScript Engine, defect)

Other Branch
x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla23
Tracking Status
firefox22 --- unaffected
firefox23 + fixed

People

(Reporter: bhackett, Unassigned)

References

Details

(Keywords: perf, regression)

Attachments

(1 file)

Attached patch patchSplinter Review
These are two bits of data stored in a script's analysis info and used during Ion compilation.  If the script has not been analyzed before Ion compilation, as is the case post bug 865059, the bits are not accumulated and the generated code is worse.  This is the cause of the dromaeo DOM/CSS regressions post bug 865059.  The attached patch allows this data to also be accumulated on a BaselineScript's ICs, and fixes the above regressions (https://tbpl.mozilla.org/?tree=Try&rev=3525a04167a6).
Attachment #746676 - Flags: review?(jdemooij)
Comment on attachment 746676 [details] [diff] [review]
patch

Review of attachment 746676 [details] [diff] [review]:
-----------------------------------------------------------------

Nice.
Attachment #746676 - Flags: review?(jdemooij) → review+
The Dromaeo DOM and Dromaeo CSS regressions appear to be completely fixed; in most cases the performance is now *better* than it was pre bug 865059:
https://groups.google.com/d/topic/mozilla.dev.tree-management/UZ7oRo6324M/discussion

Original thread for reference:
https://groups.google.com/d/topic/mozilla.dev.tree-management/qJ4I0j0CKTI/discussion
https://hg.mozilla.org/mozilla-central/rev/0f990be99e7b
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla23
You need to log in before you can comment on or make changes to this bug.