Portrait photos taken with camera appear with wrong rotation in gallery

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
6 years ago
4 years ago

People

(Reporter: cajbir, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Reporter

Description

6 years ago
When I take photo's with the camera app on the Nexus S running FxOS the resulting picture displays incorrectly in the Gallery app.

Problem:

1) Take photo with camera held in portait
2) Photo appears in gallery rotated 90 degrees as if it had been a landscape photo.

This happens whether the front or back camera is used. Landscape photo's appear fine. If I copy the image onto my computer it appears fine so I assume the gallery app is mishandling the rotation information.
Reporter

Comment 1

6 years ago
Posted image Portrait photo 1
This photo was taken with in "Portrait" on the phone but appears landscape in the gallery. It appears portrait in apps on my PC that handle rotation data correctly.
Reporter

Comment 2

6 years ago
Posted image Landscape photo
This is a photo taken in landscape which appears in the gallery correctly.
We already worked a lot on this in the past with mikeh, I think we identified the root cause as a difference between devices for the rotation reference.
I used to work this around by changing rotation in gaia, something like -270.
I think it's not valid anymore. Anyway, I'm stopping dogfooding Nexus S.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.