[regression] Change settings notification volume doesn't reflect to volume overlay

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: alive, Assigned: alive)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 fixed, b2g18-v1.0.1 verified)

Details

STR:
1. Open Settings->Sound->Volume->Change notfiication&ringer volume
2. Wait a second
3. Use volume up/volume down

Expected:
The value reflects to volume overlay

Actual:
The UI on volume overlay doesn't sync with settings app's change.


Not sure it's caused by recent silent mode change or not.
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
Depends on: 819842
Should this block tef? This sounds like broken functionality from a feature landing.
Not tef+, for now, because the one breaks this is on leo+ bug.
My work in bug 867912 would fix this.
blocking-b2g: --- → leo?
Depends on: 867912

Updated

5 years ago
blocking-b2g: leo? → leo+
Keywords: regression
resolved by uplifting bug 867912.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
status-b2g18: --- → fixed
status-b2g18-v1.0.1: --- → fixed
Inari Build: 20130530070213
Version: 18.0
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/11b55d3ada71
Gaia   ac293ce59acc3bede083fad1b973794fa8bf0253


Leo Build: 20130529070208
Version: 18.0
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/09ac1fd2959c
Gaia   1cca9324d4444ad28c6fa99875e17abf7e8230be


This bug is still reproducing on both Inari and Leo devices. No good syncing between the volume slider and using the hardware buttons to adjust the volume levels.

Comment 6

5 years ago
When the user decreases the volume to minimum using the volume rocker (hardware button), the ringer & notifications volume remains maximum. There is no syncing between the volume slider and the volume rocker. This defect still appears on LEO device.

Leo Build ID: 20130620070209
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/3e144cc723d3
Gaia: c507ff65b51194383da65f8927164f078a3e1f79
Platform Version: 18.0

This issue does not reproduce for v.1.0.1 for Inari.

Verified on Build ID: 20130621070204
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/9c62297d11b0
Gaia: 93241eb6c5d6c110710fad8da3ccd4423312b0c9
Platform Version: 18.0
status-b2g18-v1.0.1: fixed → verified
You need to log in before you can comment on or make changes to this bug.