email headers not localizable when printing

VERIFIED FIXED

Status

MailNews Core
Localization
P2
normal
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: xspuente, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

(Blocks: 1 bug, {l12y})

Trunk
x86
Windows 2000
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
When printing an email with a localized version of Mozilla 0.9.1 (Asturian,
German or Italian), the fields From:, To:, Subject: and Date:, that appear
localized in the messenger window, are printed in English.

Comment 1

17 years ago
This is mozilla localization issue.

Reassigned to tao.
Assignee: rchen → tao
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
How about printing of subject itself? For example, can you print out german 
subject? And can you print out mail body or a german web page?

Comment 3

17 years ago
Reassign to putterman.
Assignee: tao → putterman
Keywords: intl, l12y
(Reporter)

Comment 4

17 years ago
The fact is that the four strings I mentioned appear correct in the language you
choose, in the messenger window, but if you print the page, everything is the
same, but From, To,... that appear in English.
Xose

Updated

17 years ago
Keywords: intl → nsBranch

Comment 5

17 years ago
Marking nsbranch- as it was decided in the August bug triage that we wouldn't
have enough time in eMojo to fix this.  Let's revisit for MachV.
Keywords: nsbranch-

Comment 6

17 years ago
removed keyword nsbranch since bug now has nsbranch-, per pdt mtg.
Keywords: nsbranch

Comment 7

17 years ago
reassigning to sspitzer
Assignee: putterman → sspitzer

Updated

17 years ago
Blocks: 107067

Updated

17 years ago
Keywords: nsbranch-

Comment 8

17 years ago
ji - can you check and see if this is still an issue? Is this working in 6.2?

Comment 9

17 years ago
Yes, the problem is still there, it was not resolved in 6.2.
(Reporter)

Comment 10

17 years ago
No, I'm using 0.9.5 with the Asturian langpack and the printed email still
appears in English while on the screen is in Asturian.

Comment 11

17 years ago
I meant it's not working in 6.2.

Comment 12

17 years ago
Nominating for nsbeta1.
Keywords: nsbeta1

Updated

17 years ago
Keywords: nsbeta1 → nsbeta1+
Priority: -- → P2

Comment 13

17 years ago
Is this really a nsbeta1+, P2? If yes, then we need to try and targeted to a
milestone M1.0 or earlier to make the beta.
I found the problem, here comes the patch.

with my patch, I was able to edit mimeheader.properties and the new strings 
showed up in the printed version.

http://lxr.mozilla.org/mozilla/find?string=mimeheader.properties

looking at the blame log (http://bonsai.mozilla.org/cvslog.cgi?
file=mozilla/mailnews/mime/resources/mimeheader.properties) amasri@netscape.com 
 added some localizations notes.  

if localizers followed them, we wouldn't localize a few of the headers.

 25 # LOCALIZATION NOTE (BCC); DONT_TRANSLATE
 26 BCC=BCC
 27 # LOCALIZATION NOTE (CC); DONT_TRANSLATE
 28 CC=CC
 31 # LOCALIZATION NOTE (FCC); DONT_TRANSLATE
 32 FCC=FCC
 49 # LOCALIZATION NOTE (RESENT-CC); Do not translate "CC"
 50 RESENT-CC=Resent-CC

I'm not 100% certain those are correct, but I haven't investigated.
 
Status: NEW → ASSIGNED
Summary: email printing is not localizable → email headers not localizable when printing
fixed.  that simple patch has r/sr=bienvenu.

I'll log a new bug on the issues with the localization notes, and assign it to 
tao.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 18

16 years ago
Verified as fixed.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.