Closed Bug 869877 Opened 8 years ago Closed 8 years ago

[B2G][Mozilla-central][Keyboard] UI still shows other suggested words after you chose a correct one.

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 871883

People

(Reporter: whsu, Unassigned)

References

Details

Attachments

(1 file)

* Description:
  This bug is a side effect of Bug 860546.
  Once you applied the above patch, the UI shows other suggested words after you chose a correct one.
  You can refer to the attachment.

* Reproduction steps:
  1. Enable word suggestion
  2. Launch contact app and tap "+" icon to add a contact
  3. Tap name field to edit the name
  4. Tap "t", "h", and "i" then chose the suggested word "this"

* Expected result:
  The "This" will show on UI then the field of word suggestion will be empty.

* Actual result:
  The "This" will show on UI then other words show on UI.

* Reproduction build:(Mozilla-central-unagi/20130506031043)
  + Mercurial-Information
    - Gecko revision="b109e2dbf03b"
    - Gaia revision=""
  + Git-information
    - Gecko revision="61322a468cf3b98bb01bf58843ae47754f747f50"
    - Gaia revision="5b50627a6da022258593cecc05dd8e0302f93a6f"
Thanks!
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
Depends on: 860546
No longer depends on: 860546
It should be fixed by Bug 871883.
Let's dupe then.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 871883
Too much unclear information connected together.
Not sure whether we have verified related patch so I append verification information here.

I have verified related patch.
I cannot reproduce this bug with latest v1-train build.
* Mozilla-b2g18-unagi-eng/2013-06-20-23-02-08
  + Mercurial-Information:
    - Gecko revision: "a34f6d62cb05"
    - Gaia revision:
  + Git-information
    - Gecko revision: "243a03062a9e6cfa2e315298ed5b45352ae829e8"
    - Gaia revision: "de211a86e1df621415942e8b02acea77efafd864"
You need to log in before you can comment on or make changes to this bug.