Closed Bug 870375 Opened 8 years ago Closed 8 years ago

Keon startup crash after bug 869011

Categories

(Core :: Graphics: Layers, defect)

23 Branch
ARM
Gonk (Firefox OS)
defect
Not set
critical

Tracking

()

RESOLVED FIXED

People

(Reporter: fabrice, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression, Whiteboard: [b2g-crash][startupcrash])

Crash Data

We crash in the parent process:

Process /system/b2g/b2g created; pid = 29775
Listening on port 11000
prebuilt/linux-x86/toolchain/arm-linux-androideabi-4.4.x/bin/arm-linux-androideabi-gdb -x /tmp/b2g.gdbinit.fabrice /home/fabrice/dev/b2g/B2G/objdir-gecko/dist/bin/b2g
GNU gdb (GDB) 7.1-android-gg2
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "--host=i686-linux-gnu --target=arm-elf-linux".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /home/fabrice/dev/b2g/B2G/objdir-gecko/dist/bin/b2g...done.
Remote debugging from host 127.0.0.1
__dl__start () at bionic/linker/arch/arm/begin.S:35
35		mov	r0, sp
(gdb) c
Continuing.
[New Thread 29775.29804]
###################################### forms.js loaded
############################### browserElementPanning.js loaded
######################## BrowserElementChildPreload.js loaded
Crash reporter : Can't fetch app.reportCrashes. Exception: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getBoolPref]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: chrome://browser/content/shell.js :: shell_reportCrash :: line 130"  data: no]###################################### forms.js loaded
############################### browserElementPanning.js loaded
######################## BrowserElementChildPreload.js loaded
XXX FIXME : Got a mozContentEvent: system-message-listener-ready
[New Thread 29775.29796]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 29775.29796]
0x41dd0dfa in mozalloc_abort (msg=<value optimized out>) at /home/fabrice/dev/inbound/memory/mozalloc/mozalloc_abort.cpp:30
30	    MOZ_CRASH();
(gdb) bt
#0  0x41dd0dfa in mozalloc_abort (msg=<value optimized out>) at /home/fabrice/dev/inbound/memory/mozalloc/mozalloc_abort.cpp:30
#1  0x41dd0e10 in abort () at /home/fabrice/dev/inbound/memory/mozalloc/mozalloc_abort.cpp:39
#2  0x41dd0e10 in abort () at /home/fabrice/dev/inbound/memory/mozalloc/mozalloc_abort.cpp:39
Backtrace stopped: previous frame identical to this frame (corrupt stack?)
Blocks: 869011
Severity: normal → critical
Crash Signature: [@ mozalloc_abort(char const*) | NS_DebugBreak ]
Keywords: crash, regression
Whiteboard: [b2g-crash][startupcrash]
Version: unspecified → 23 Branch
I'm also seeing a startup crash on the leo device. I'm backing this out since this blocks all m-c work on a large number of our devices.
You need to log in before you can comment on or make changes to this bug.