Add attachments on translated articles

RESOLVED FIXED

Status

developer.mozilla.org
General
P1
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Thierry Régagnon, Unassigned)

Tracking

Details

(Whiteboard: [specification][type:feature])

(Reporter)

Description

5 years ago
What problems would this solve?
===============================
I started to translate this page in French (about Firefox' Page Inspector)
https://developer.mozilla.org/fr/docs/Outils/inspecteur

It contains images with text.

I wanted to upload screenshots from the French version of Firefox with translated explanations. But I couldn't add an attachment from the translation interface, nor reference an attachment from the original article with CKEditor.

Who would use this?
===================
Translators could translate images, or add localized screenshots of Firefox / Firefox OS.

What would users see?
=====================
In the translation edit form, there should be the same "Attach files" form as the one on the original article edit interface.

I think we should see attachments from the original article separated from the attachments of the translated article.


What would users do? What would happen as a result?
===================================================
Translators could add new attachments and reference them in the article.

We should also be able to reference attachments from the original article in CKEditor.

Is there anything else we should know?
======================================

Updated

5 years ago
Duplicate of this bug: 868750

Comment 2

5 years ago
This needs to be added into the backlog
Priority: -- → P1

Comment 4

5 years ago
Commits pushed to master at https://github.com/mozilla/kuma

https://github.com/mozilla/kuma/commit/badf91f434b13613bbf673af034eb1c1c40f0b1d
fix bug 870391 - Allow attachments in translations

https://github.com/mozilla/kuma/commit/d1c1adc282cb4d88d275e66ba86cd7bb7ee6b7c6
Merge pull request #1182 from darkwing/attach-translate-870391

fix bug 870391 - Allow attachments in translations

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.