Add 'Clear Recent History', 'Restore Previous Session', and tweak some of the text

RESOLVED FIXED in Firefox 28

Status

()

--
enhancement
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: ge3k0s, Assigned: jaws)

Tracking

(Blocks: 1 bug)

unspecified
Firefox 28
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Australis:M6][good first verify])

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
I think the history subview could be done differently.

There should be first three general items :
-Show all history instead of "more" at the bottom.
-Clear recent History... -> bring the clear history dialog (or second subview).
-Restore previous session.

If possible "Recently closed" (tabs and windows will be merged) -> this too would need UI (second subview ?).

And then the history last items.

If general commands aren't present it would be a pretty big regression compared to the old menu and these items would be accessible only via the menu bar and shortcuts. 

I know that subview inside a subview looks a bit "Inception-esque" but for certain items it should be at least considered.
(Reporter)

Updated

6 years ago
Blocks: 770135
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Reorganize history subview → Add 'Clear Recent History', 'Restore Previous Session', and tweak some of the text
No longer blocks: 770135
Whiteboard: [Australis:M6]
(Reporter)

Comment 1

6 years ago
The tooltip of the widget should also be changed since "History repeats itself" is fun, but not very useful.
Created attachment 752022 [details] [diff] [review]
Patch

I left out the Recently Closed Tabs + Windows for now since it will probably require another subview or some other UI that we haven't figured out yet.
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Attachment #752022 - Flags: review?(gijskruitbosch+bugs)
Note that the attached patch is dependent upon the patch in bug 874319.
Depends on: 874319

Comment 4

6 years ago
Comment on attachment 752022 [details] [diff] [review]
Patch

Review of attachment 752022 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, r=me
Attachment #752022 - Flags: review?(gijskruitbosch+bugs) → review+
Comment on attachment 752022 [details] [diff] [review]
Patch

> <!ENTITY historyHomeCmd.label "Home">
> <!ENTITY showAllHistoryCmd2.label "Show All History">
> <!ENTITY showAllHistoryCmd.commandkey "H">
> 
> <!ENTITY appMenuCustomize.label "Customize">
> <!ENTITY appMenuBookmarks.label "Bookmarks">
> <!ENTITY appMenuHistory.label "History">
>-<!ENTITY appMenuHistoryMore.label "More…">
>+<!ENTITY appMenuHistory.moreLabel "Show All History">
>+<!ENTITY appMenuHistory.clearRecentLabel "Clear Recent History…">
>+<!ENTITY appMenuHistory.restoreSession "Restore Previous Session">

You missed the 'label' suffix for restoreSession. Also, where you do have the suffix, it's weird that you didn't separate it with a dot like it's usually done for label, accesskey, description, commandkey, tooltip etc.

Comment 7

6 years ago
Created attachment 752642 [details] [diff] [review]
Change l10n ids per dao's feedback

> You missed the 'label' suffix for restoreSession. Also, where you do have
> the suffix, it's weird that you didn't separate it with a dot like it's
> usually done for label, accesskey, description, commandkey, tooltip etc.

As this is not on m-c yet, figure we might as well change this still?
Attachment #752642 - Flags: review?(dao)
Comment on attachment 752642 [details] [diff] [review]
Change l10n ids per dao's feedback

appMenuHistory.more.label should probably be appMenuHistory.showAll.label?
Attachment #752642 - Flags: review?(dao) → review+

Comment 9

6 years ago
(In reply to Dão Gottwald [:dao] from comment #8)
> Comment on attachment 752642 [details] [diff] [review]
> Change l10n ids per dao's feedback
> 
> appMenuHistory.more.label should probably be appMenuHistory.showAll.label?

Pushed to UX with that change: https://hg.mozilla.org/projects/ux/rev/1718434171c2

Comment 10

5 years ago
https://hg.mozilla.org/mozilla-central/rev/03bae1732987
https://hg.mozilla.org/mozilla-central/rev/1718434171c2
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:M6][fixed in ux] → [Australis:M6]
Target Milestone: --- → Firefox 28

Updated

5 years ago
Whiteboard: [Australis:M6] → [Australis:M6][good first verify]
You need to log in before you can comment on or make changes to this bug.