[AAQ Flow] Create a Device Picker for Firefox OS

RESOLVED WONTFIX

Status

support.mozilla.org
Questions
P2
normal
RESOLVED WONTFIX
5 years ago
2 years ago

People

(Reporter: ibai, Unassigned)

Tracking

unspecified
Future

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=user c=aaq p= s=2013.backlog)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 747551 [details]
Phone Selection for Firefox OS AAQ

When entering the Firefox OS questions in the AAQ flow we will need to identify the device so we can identify the build.

Until we can do this automatically through an API we can have a low level solution that basically shows pictures of the devices that we have launched.

We need to identity where is the best place to add this form. 

Because Articles are not yet Build specifics, we can wait to show this until the question is typed and the user is entering the details.

https://support.mozilla.org/en-US/questions/new/firefox-os/$topic/form?search=$query&step=aaq-question

I think that between the text box and the post question is the natural fit for this. I'm attaching a visual description of this idea.
(Reporter)

Comment 1

5 years ago
Michelle, it would be great if you could provide catalog pictures of the devices that we are going to launch.
Flags: needinfo?(mluna)
This might get crazy.
Whiteboard: u=user c=aaq p= s=2013.10
Priority: -- → P2
Target Milestone: --- → 2013Q2
Leaving in the backlog for now until we figure it all out.
Whiteboard: u=user c=aaq p= s=2013.10 → u=user c=aaq p= s=2013.backlog

Comment 4

5 years ago
Yes. My experience working with Marketplace indicates that this will get crazy.

For starters, though, it would help to get a full list of device that we’ll need to support at launch. Who should we ask for this?
Instead of automatically determining, could we ask the user what their device is instead? I opened up a bug for that. Bug 909629
Duplicate of this bug: 909629
Target Milestone: 2013Q2 → Future
No longer blocks: 861430

Comment 7

3 years ago
Michelle is no longer with us, Hermina, Ralph do you still want to do this?
Flags: needinfo?(rdaub)
Flags: needinfo?(mluna)
Flags: needinfo?(hcondei)

Comment 8

3 years ago
Hi Madalina,

From what I know, we are able to get the data from the user agent without asking the user. Hence, no need for this. The bug should be closed.

Thanks,
Hermina
Flags: needinfo?(hcondei)

Comment 9

3 years ago
Thanks Hermina, closing then.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
We definitely are able to sniff out device info now :)
Flags: needinfo?(rdaub)

Comment 11

3 years ago
Reopening this bug - please feel free to assign lower priority (for backlog) or resolve it.

The information is sniffed (Device manufacturer, Device model, version) only when the user asks a question using a Firefox OS device. When a user asks from a computer or another device, there is no device information assigned to the question for obvious reasons.

It would still be "useful/nice" to have a device picker for users asking a question from a computer or another device, or when SUMO isn't able to sniff this information correctly. It would also be useful to be able to tell the device's market, since builds for the same device can be different in other countries/markets.

Currently, a "Request More Information" type of answer is used as a first reply in roughly 33% of the questions asked in the forums.

+needinfo to Madalina, Hermina, to decide on keeping the bug open or resolving, given my feedback.
Status: RESOLVED → REOPENED
Flags: needinfo?(mana)
Flags: needinfo?(hcondei)
Resolution: WORKSFORME → ---

Comment 12

3 years ago
I'll put in on the prioritized list as low priority.
Flags: needinfo?(mana)

Updated

3 years ago
Flags: needinfo?(hcondei)
Firefox OS is no longer with us, so this is very unlikely to happen.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.