The Geolocation prompt should not offer action in PB mode if the action remembers permission for more than a session.

RESOLVED FIXED in seamonkey2.21

Status

SeaMonkey
UI Design
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Philip Chee, Assigned: Philip Chee)

Tracking

Trunk
seamonkey2.21
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.18 fixed, seamonkey2.19 fixed, seamonkey2.20 fixed, seamonkey2.21 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Spun off from Bug 870413 Comment 3:
>> +            if (site && !this.usePrivateBrowsing) {
> Eek. Should backport this I guess...
(Assignee)

Comment 1

4 years ago
Created attachment 747893 [details] [diff] [review]
Patch v1.0 Proposed fix.

I've split this patch off from Bug 870413 so that we can land this on all branches including comm-release.
Assignee: nobody → philip.chee
Status: NEW → ASSIGNED
Attachment #747893 - Flags: review?(neil)

Updated

4 years ago
Attachment #747893 - Flags: review?(neil) → review+
(Assignee)

Comment 2

4 years ago
a-beta=Callek a=CLOSED TREE 
Pushed to comm-beta:
http://hg.mozilla.org/releases/comm-beta/rev/fb4f91ec5302
status-seamonkey2.18: --- → fixed
(Assignee)

Comment 3

4 years ago
Pushed to comm-central: http://hg.mozilla.org/comm-central/rev/39546ca48c28
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-seamonkey2.21: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.21
(Assignee)

Comment 4

4 years ago
Comment on attachment 747893 [details] [diff] [review]
Patch v1.0 Proposed fix.

Firefox Bug 496595 (Privacy leak in "remember for this site" permission of geolocation - persists outside of private browsing) landed on Firefox 3.6a1

[Approval Request Comment]
Bug caused by (feature/regressing bug #):
Privacy leak in "remember for this site" permission of geolocation

User impact if declined: Privacy leak in "remember for this site" permission of geolocation. Since this patch has already landed on SM 2.18 and SM2.21 we should ensure that it also lands on 2.19 and 2.20.

Testing completed (on m-c, etc.): Has been running for a while on my self build. The firefox version of this bug has been running since Fx3.6a1.

Risk to taking this patch (and alternatives if risky):
Risk is low.

String or IDL/UUID changes made by this patch:
Attachment #747893 - Flags: approval-mozilla-beta?
Attachment #747893 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

4 years ago
status-seamonkey2.19: --- → affected
status-seamonkey2.20: --- → affected

Updated

4 years ago
Attachment #747893 - Flags: approval-mozilla-beta?
Attachment #747893 - Flags: approval-mozilla-aurora?
Attachment #747893 - Flags: approval-comm-beta?
Attachment #747893 - Flags: approval-comm-aurora?

Updated

4 years ago
Attachment #747893 - Flags: approval-comm-beta?
Attachment #747893 - Flags: approval-comm-beta+
Attachment #747893 - Flags: approval-comm-aurora?
Attachment #747893 - Flags: approval-comm-aurora+
(Assignee)

Comment 5

4 years ago
Pushed to comm-beta (SeaMonkey 2.19b)
https://hg.mozilla.org/releases/comm-beta/rev/659a7205d5b9
Pushed to comm-aurora (SeaMonkey 2.20a)
https://hg.mozilla.org/releases/comm-aurora/rev/9cf36ae1f02a
status-seamonkey2.19: affected → fixed
status-seamonkey2.20: affected → fixed
(Assignee)

Updated

4 years ago
Blocks: 595437
You need to log in before you can comment on or make changes to this bug.