bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

file descriptor leak causing empty dumps on Android

RESOLVED DUPLICATE of bug 870165

Status

()

Firefox for Android
General
--
critical
RESOLVED DUPLICATE of bug 870165
5 years ago
5 years ago

People

(Reporter: ted, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

I'm not sure where to file this, but I've hit a few crashes on my Nexus 4 recently which resulted in empty minidumps. The crash itself is some GFX assertion failing, which should be a fairly safe mozalloc_abort. However, logcat shows that we're running out of file descriptors, which makes Breakpad unable to write a dump. I filed bug 869917 on making Breakpad handle this situation, but the fact that we're leaking FDs seems pretty bad.

https://crash-stats.mozilla.com/report/index/bp-ef5de0a3-1b4b-46dd-823f-8bed92130508

The logcat has a bunch of lines like:
05-08 07:33:31.416 31341 31872 E Gecko   : ShmemAndroid::Create():open: Too many open files (24)

Cwiiis suggested this might be fallout from layers refactoring.
Another crash:
https://crash-stats.mozilla.com/report/index/bp-9d9e4c44-74df-4339-95db-89c652130509

Same stuff about too many open files in the logcat, but crashing in a different place.

Updated

5 years ago
See Also: → bug 870165
This is probably just a straight dupe, thanks.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 870165
You need to log in before you can comment on or make changes to this bug.