Last Comment Bug 870755 - Visitors are trapped in webpage when onbeforeunload event is attached unlimited iframes
: Visitors are trapped in webpage when onbeforeunload event is attached unlimit...
Status: RESOLVED DUPLICATE of bug 636374
:
Product: Firefox
Classification: Client Software
Component: Untriaged (show other bugs)
: 20 Branch
: x86_64 Windows 7
-- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-10 05:40 PDT by emrekabakci
Modified: 2015-01-23 05:52 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description User image emrekabakci 2013-05-10 05:40:37 PDT
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.81 Safari/537.36

Steps to reproduce:

1. created a few iframes
2. attached each of them onbeforeunload event
3. waited for user to exit the page



Actual results:

Users are trapped in the web page.


Expected results:

There should be a limit of onbeforeunload event callback for outer window or the browser should prevent onbeforeunload event to attach an iframe's window.
Comment 1 User image [:Aleksej] 2013-05-14 05:50:06 PDT
Thanks for the report.

*** This bug has been marked as a duplicate of bug 636374 ***

Note You need to log in before you can comment on or make changes to this bug.