Closed Bug 870762 Opened 9 years ago Closed 9 years ago

Intermittent Android "FATAL EXCEPTION: main", "java.lang.RuntimeException: Unable to start service com.mozilla.watcher.WatcherService Caused by: java.lang.NullPointerException"

Categories

(Testing Graveyard :: SUTAgent, defect)

ARM
Android
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 877939

People

(Reporter: emorley, Unassigned)

References

Details

(Keywords: crash, intermittent-failure)

{
REFTEST TEST-START | http://10.250.49.160:30096/tests/dom/media/tests/crashtests/837421.html | 557 / 2362 (23%)
REFTEST TEST-PASS | http://10.250.49.160:30096/tests/dom/media/tests/crashtests/837421.html | (LOAD ONLY)
REFTEST INFO | Loading a blank page
RESTORE PREFERENCE pref(media.navigator.permission.disabled,false)
RESTORE PREFERENCE pref(media.peerconnection.enabled,false)
SET PREFERENCE pref(media.peerconnection.enabled,true)
SET PREFERENCE pref(media.navigator.permission.disabled,true)
REFTEST TEST-START | http://10.250.49.160:30096/tests/dom/media/tests/crashtests/855796.html | 558 / 2362 (23%)

INFO | automation.py | Application ran for: 0:04:09.241166
INFO | zombiecheck | Reading PID log: /tmp/tmpEXFa28pidlog
WARNING | leakcheck | refcount logging is off, so leaks can't be detected!

REFTEST INFO | runreftest.py | Running tests: end.
}

From logcat:
{
05-09 19:26:44.754 D/GeckoLayerClient( 1692): Aborting update due to viewport not in display-port
05-09 19:26:44.847 E/GeckoConsole( 1692): [JavaScript Warning: "Invalid URI. Load of media resource  failed." {file: "http://10.250.49.160:30096/tests/dom/media/tests/crashtests/812785.html" line: 0}]
05-09 19:26:44.847 E/GeckoConsole( 1692): [JavaScript Warning: "All candidate resources failed to load. Media load paused." {file: "http://10.250.49.160:30096/tests/dom/media/tests/crashtests/812785.html" line: 0}]
05-09 19:26:44.924 D/GeckoLayerClient( 1692): Aborting update due to viewport not in display-port
05-09 19:26:44.994 D/GeckoLayerClient( 1692): Aborting update due to viewport not in display-port
05-09 19:26:45.004 D/GeckoLayerClient( 1692): Aborting update due to viewport not in display-port
05-09 19:26:45.014 D/GeckoLayerClient( 1692): Aborting update due to viewport not in display-port
05-09 19:26:45.034 D/GeckoLayerClient( 1692): Aborting update due to viewport not in display-port
05-09 19:26:45.054 D/GeckoLayerClient( 1692): Aborting update due to viewport not in display-port
05-09 19:26:47.977 I/SUTAgentAndroid( 1492): 10.250.49.160 : activity
05-09 19:26:48.007 I/SUTAgentAndroid( 1492): 10.250.49.160 : isdir /mnt/sdcard/tests/reftest
05-09 19:26:48.037 I/SUTAgentAndroid( 1492): 10.250.49.160 : cd /mnt/sdcard/tests/reftest
05-09 19:26:48.067 I/SUTAgentAndroid( 1492): 10.250.49.160 : ls
05-09 19:26:48.097 I/SUTAgentAndroid( 1492): 10.250.49.160 : pull /mnt/sdcard/tests/reftest/reftest.log
05-09 19:26:49.684 D/GeckoLayerClient( 1692): Aborting update due to viewport not in display-port
05-09 19:26:51.604 E/GeckoConsole( 1692): [JavaScript Error: "TypeError: ld is null" {file: "http://10.250.49.160:30096/tests/dom/media/tests/crashtests/836349.html" line: 14}]
05-09 19:26:53.124 I/SUTAgentAndroid( 1492): 10.250.49.160 : activity
05-09 19:26:53.154 I/SUTAgentAndroid( 1492): 10.250.49.160 : isdir /mnt/sdcard/tests/reftest
05-09 19:26:53.184 I/SUTAgentAndroid( 1492): 10.250.49.160 : cd /mnt/sdcard/tests/reftest
05-09 19:26:53.214 I/SUTAgentAndroid( 1492): 10.250.49.160 : ls
05-09 19:26:53.244 I/SUTAgentAndroid( 1492): 10.250.49.160 : pull /mnt/sdcard/tests/reftest/reftest.log
...
...
...
05-09 19:28:27.884 I/ActivityManager( 1017): Process android.process.acore (pid 1264) has died.
05-09 19:28:28.104 I/SUTAgentAndroid( 1492): 10.250.49.160 : activity
05-09 19:28:34.794 I/ActivityManager( 1017): Process com.android.settings (pid 1234) has died.
05-09 19:28:34.794 I/ActivityManager( 1017): Process com.android.mms (pid 1360) has died.
05-09 19:28:34.794 I/ActivityManager( 1017): Process com.android.bluetooth (pid 1403) has died.
05-09 19:28:34.794 I/ActivityManager( 1017): Process com.android.quicksearchbox (pid 1450) has died.
05-09 19:28:34.794 I/ActivityManager( 1017): Process com.cooliris.media (pid 1459) has died.
05-09 19:28:34.794 I/ActivityManager( 1017): Process com.android.defcontainer (pid 1559) has died.
05-09 19:28:34.794 I/ActivityManager( 1017): Process org.mozilla.f3nn3c.UpdateService (pid 1765) has died.
05-09 19:28:34.904 I/WindowManager( 1017): WIN DEATH: Window{44414488 com.android.launcher/com.android.launcher2.Launcher paused=false}
05-09 19:28:35.054 I/WindowManager( 1017): WIN DEATH: Window{445c9b50 org.mozilla.fennec/org.mozilla.fennec.App paused=false}
05-09 19:28:35.054 I/ActivityManager( 1017): Process com.svox.pico (pid 1574) has died.
05-09 19:28:35.064 I/WindowManager( 1017): WIN DEATH: Window{445ca488 SurfaceView paused=false}
05-09 19:28:35.064 I/ActivityManager( 1017): Process com.android.music (pid 1438) has died.
05-09 19:28:35.064 I/ActivityManager( 1017): Process com.android.providers.calendar (pid 1416) has died.
05-09 19:28:35.074 I/ActivityManager( 1017): Process android.process.media (pid 1336) has died.
05-09 19:28:35.074 I/ActivityManager( 1017): Process com.android.email (pid 1345) has died.
05-09 19:28:35.074 I/ActivityManager( 1017): Process com.android.launcher (pid 1226) has died.
05-09 19:28:35.094 I/ActivityManager( 1017): Process com.android.deskclock (pid 1324) has died.
05-09 19:28:35.104 I/ActivityManager( 1017): Low Memory: No more background processes.
05-09 19:28:35.104 I/ActivityManager( 1017): Process org.mozilla.fennec (pid 1692) has died.
05-09 19:28:35.254 I/UsageStats( 1017): Unexpected resume of com.mozilla.SUTAgentAndroid while already resumed in org.mozilla.fennec
05-09 19:28:35.314 I/ActivityManager( 1017): Low Memory: No more background processes.
05-09 19:28:35.314 I/ActivityManager( 1017): Process com.mozilla.watcher (pid 1430) has died.
05-09 19:28:35.314 W/ActivityManager( 1017): Scheduling restart of crashed service com.mozilla.watcher/.WatcherService in 5000ms
05-09 19:28:35.314 I/ActivityManager( 1017): Low Memory: No more background processes.
05-09 19:28:35.454 I/SUTAgentAndroid( 1492): 10.250.49.160 : isdir /mnt/sdcard/tests/reftest
05-09 19:28:35.564 I/SUTAgentAndroid( 1492): 10.250.49.160 : cd /mnt/sdcard/tests/reftest
05-09 19:28:35.684 I/SUTAgentAndroid( 1492): 10.250.49.160 : ls
05-09 19:28:35.744 I/SUTAgentAndroid( 1492): 10.250.49.160 : pull /mnt/sdcard/tests/reftest/reftest.log
05-09 19:28:35.794 D/KeyguardViewMediator( 1017): pokeWakelock(5000)
05-09 19:28:35.794 D/StatusBar( 1017): DISABLE_EXPAND: yes
05-09 19:28:35.804 I/ActivityManager( 1017): Start proc com.android.settings for broadcast com.android.settings/.widget.SettingsAppWidgetProvider: pid=1863 uid=1000 gids={3002, 3001, 3003}
05-09 19:28:36.054 I/ActivityManager( 1017): Displayed activity com.mozilla.SUTAgentAndroid/.SUTAgentAndroid: 445158 ms (total 445158 ms)
05-09 19:28:40.354 I/ActivityManager( 1017): Start proc com.mozilla.watcher for service com.mozilla.watcher/.WatcherService: pid=1881 uid=10032 gids={}
05-09 19:28:40.424 I/global  ( 1881): Default buffer size used in BufferedReader constructor. It would be better to be explicit if an 8k-char buffer is required.
05-09 19:28:40.434 I/global  ( 1881): Default buffer size used in BufferedReader constructor. It would be better to be explicit if an 8k-char buffer is required.
05-09 19:28:40.434 I/global  ( 1881): Default buffer size used in BufferedReader constructor. It would be better to be explicit if an 8k-char buffer is required.
05-09 19:28:40.434 I/global  ( 1881): Default buffer size used in BufferedReader constructor. It would be better to be explicit if an 8k-char buffer is required.
05-09 19:28:40.444 W/Service ( 1881): setForeground: ignoring old API call on com.mozilla.watcher.WatcherService
05-09 19:28:40.444 W/InputManagerService( 1017): Got RemoteException sending setActive(false) notification to pid 1692 uid 10033
05-09 19:28:40.464 D/AndroidRuntime( 1881): Shutting down VM
05-09 19:28:40.464 W/dalvikvm( 1881): threadid=1: thread exiting with uncaught exception (group=0x4001d820)
05-09 19:28:40.484 E/AndroidRuntime( 1881): FATAL EXCEPTION: main
05-09 19:28:40.484 E/AndroidRuntime( 1881): java.lang.RuntimeException: Unable to start service com.mozilla.watcher.WatcherService@442ce890 with null: java.lang.NullPointerException
05-09 19:28:40.484 E/AndroidRuntime( 1881): 	at android.app.ActivityThread.handleServiceArgs(ActivityThread.java:3063)
05-09 19:28:40.484 E/AndroidRuntime( 1881): 	at android.app.ActivityThread.access$3600(ActivityThread.java:125)
05-09 19:28:40.484 E/AndroidRuntime( 1881): 	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:2096)
05-09 19:28:40.484 E/AndroidRuntime( 1881): 	at android.os.Handler.dispatchMessage(Handler.java:99)
05-09 19:28:40.484 E/AndroidRuntime( 1881): 	at android.os.Looper.loop(Looper.java:123)
05-09 19:28:40.484 E/AndroidRuntime( 1881): 	at android.app.ActivityThread.main(ActivityThread.java:4627)
05-09 19:28:40.484 E/AndroidRuntime( 1881): 	at java.lang.reflect.Method.invokeNative(Native Method)
05-09 19:28:40.484 E/AndroidRuntime( 1881): 	at java.lang.reflect.Method.invoke(Method.java:521)
05-09 19:28:40.484 E/AndroidRuntime( 1881): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:868)
05-09 19:28:40.484 E/AndroidRuntime( 1881): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:626)
05-09 19:28:40.484 E/AndroidRuntime( 1881): 	at dalvik.system.NativeStart.main(Native Method)
05-09 19:28:40.484 E/AndroidRuntime( 1881): Caused by: java.lang.NullPointerException
05-09 19:28:40.484 E/AndroidRuntime( 1881): 	at com.mozilla.watcher.WatcherService.handleCommand(WatcherService.java:160)
05-09 19:28:40.484 E/AndroidRuntime( 1881): 	at com.mozilla.watcher.WatcherService.onStartCommand(WatcherService.java:201)
05-09 19:28:40.484 E/AndroidRuntime( 1881): 	at android.app.ActivityThread.handleServiceArgs(ActivityThread.java:3053)
05-09 19:28:40.484 E/AndroidRuntime( 1881): 	... 10 more
}
Err, missed out:

Android Tegra 250 mozilla-inbound opt test crashtest on 2013-05-09 19:16:57 PDT for push d43e27c6362e

slave: tegra-096

https://tbpl.mozilla.org/php/getParsedLog.php?id=22802358&tree=Mozilla-Inbound
Depends on: 872116
Forward duping since more info in that bug.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 877939
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.