Ctrl+W no longer close the tab when the Web Console is focused

VERIFIED FIXED in Firefox 23

Status

defect
VERIFIED FIXED
6 years ago
Last year

People

(Reporter: emk, Assigned: msucan)

Tracking

({regression})

23 Branch
Firefox 24
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox22 unaffected, firefox23+ verified, firefox24+ verified)

Details

Attachments

(1 attachment)

Steps to reproduce:
1. Press Ctrl+Shift+K to open the Web Console.
2. Make sure the Web Console has the focus.
3. Press Ctrl+W.

Actual result:
Nothing happens.

Expected result:
The current tab should be closed. Firefox 20 worked as expected.
good=2013-04-09
bad=2013-04-10
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b1fb34b07c17&tochange=9db46ddfb517

One of 3 bugs, probably:
Mihai Sucan — Bug 587757 - (global-console) Implement Browser Console; r=past,jwalker,Mossop
Mihai Sucan — Bug 808370 - Use the VariablesView in webconsole; r=past,vporof,paul
Mihai Sucan — Bug 783499 - Web Console should use the debugger API; r=past
Component: Developer Tools → Developer Tools: Console
Keywords: regression
Version: 20 Branch → 23 Branch
Masatoshi, thank you for the bug report.

Loic, thanks for the regression window. This bug is caused by the global-console patch indeed.

I will submit a fix ASAP.
Assignee: nobody → mihai.sucan
Status: NEW → ASSIGNED
OS: Windows 8 → All
Hardware: x86_64 → All
Posted patch proposed fixSplinter Review
This patch fixes the bug and adds a test to make sure Ctrl-W works as expected in the Web Console and in the Browser Console.

Try push: https://tbpl.mozilla.org/?tree=Try&rev=6f46fc3b114c

We will want this patch to land in Aurora as well.
Attachment #750396 - Flags: review?(rcampbell)
Comment on attachment 750396 [details] [diff] [review]
proposed fix

Review of attachment 750396 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/devtools/webconsole/HUDService.jsm
@@ +548,5 @@
>        let title = this.ui.rootElement.getAttribute("browserConsoleTitle");
>        this.ui.rootElement.setAttribute("title", title);
> +
> +      let cmd_close = this.ui.document.getElementById("cmd_close");
> +      cmd_close.removeAttribute("disabled");

so, we disable cmd_close on general web consoles and enable it on browser console? makes sense.

::: browser/devtools/webconsole/test/browser_bug_871156_ctrlw_close_tab.js
@@ +62,5 @@
> +
> +      EventUtils.synthesizeKey("w", { accelKey: true }, hud.iframeWindow);
> +    });
> +  }
> +}

nice.

::: toolkit/devtools/Console.jsm
@@ +188,5 @@
>        }
>      }
> +    else if (type.match("Error$") ||
> +             (typeof aThing.name == "string" &&
> +              aThing.name.match("NS_ERROR_"))) {

did this have something to do with closing the tab or are you just adding some extra error catching smarts to the console?
Attachment #750396 - Flags: review?(rcampbell) → review+
Thanks for the r+!

(In reply to Rob Campbell [:rc] (:robcee) from comment #4)
> ::: toolkit/devtools/Console.jsm
> @@ +188,5 @@
> >        }
> >      }
> > +    else if (type.match("Error$") ||
> > +             (typeof aThing.name == "string" &&
> > +              aThing.name.match("NS_ERROR_"))) {
> 
> did this have something to do with closing the tab or are you just adding
> some extra error catching smarts to the console?

This change is unrelated to this bug. I had an XPCOM exception in my code while working on it and Console.jsm wasn't playing nice. I fixed it such that the exception is displayed correctly.

I wasn't sure if I should piggyback this change here or to create a separate bug. We do not generally want to spend too much time on Console.jsm, hence I decided that "slipping" gradual improvements is acceptable. I can split it into a separate patch if you want.
Landed:
https://hg.mozilla.org/integration/fx-team/rev/1e2fd4d04d61
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/1e2fd4d04d61
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 24
Comment on attachment 750396 [details] [diff] [review]
proposed fix

[Approval Request Comment]
Bug caused by (feature/regressing bug #): regression caused by bug 587757
User impact if declined: Ctrl-W to close the current tab won't work if the user is in the web console.
Testing completed (on m-c, etc.): mochitest included, green try runs, landed in fx-team and m-c.
Risk to taking this patch (and alternatives if risky): minimal to none.
String or IDL/UUID changes made by this patch: none.

Thank you!
Attachment #750396 - Flags: approval-mozilla-aurora?
Attachment #750396 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Depends on: 874635
Keywords: verifyme
Mozilla/5.0 (X11; Linux i686; rv:24.0) Gecko/20100101 Firefox/24.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:24.0) Gecko/20100101 Firefox/24.0

Verified fixed on Firefox 23.0.1 (buildID: 20130814063812) and Firefox 24 beta 10 (buildID: 20130909203154).
Status: RESOLVED → VERIFIED
Keywords: verifyme
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.