Closed Bug 871275 Opened 8 years ago Closed 5 years ago

The time open stat is modified after updating to the latest version

Categories

(Firefox Health Report Graveyard :: Client: Desktop, defect, P4)

21 Branch
x86
Windows XP
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: simona.marcu, Unassigned)

Details

(Whiteboard: [measurement:client])

Mozilla/5.0 (Windows NT 5.1; rv:21.0) Gecko/20100101 Firefox/21.0
Build ID: 20130511120803

Steps to reproduce:
1. Install a repack build (aol or bing) from:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/20.0-candidates/build1/partner-repacks/aol/
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/20.0.1-candidates/build1/partner-repacks/bing/
2. Launch the installed build with a new profile and update to the latest version (go to Help menu-> About:Firefox)
3. After Firefox is restarted go to Help menu and check the Firefox Health Report.

Actual results:
After the update, the time open stat indicates that Firefox has been open for a couple of minutes (1-2 min).

Expected results:
After the update, the time open stat indicates that Firefox has been open for 1650 min.

Note: 
Issue reproducible on normal and repack builds.
Please keep in mind that the issue might be intermittent, and will investigate and give more details as soon as possible.
Did you mix up your Actual and Expected results?
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #2)
> Did you mix up your Actual and Expected results?

On a better look I would have to say that I did mixed up the Actual and Expected results. Sorry for that.
can QA see if this is still valid please?
Flags: needinfo?(alexandra.lucinet)
Priority: -- → P4
Whiteboard: [measurement:client]
Unable to reproduce this issue with normal builds (please see the results below); unfortunately, I couldn't find any repack builds via ftp. If anyone could point me to the correct link, it would be greatly appreciated!

Results:
* under Windows 7 64-bit:
** launched 44.0a1 (2015-09-24) + updated to latest 46.0a1 ⇒ time open = 1 minutes
** launched 44.0a1 (2015-09-24) + updated to latest 46.0a1 ⇒ time open = 1 minutes
** launched 43.0RC + updated to 43.0.4 ⇒ time open = 1 minutes

* under Mac OS X 10.10.4 
** launched 42.0 build 2 + updated to 43.0.4 ⇒ time open = 0 minutes
** launched 43.0 build 1 + updated to 43.0.4 ⇒ time open = 1 minutes
** launched 46.0a1 (2016-01-13) + updated to latest 46.0a1 ⇒ time open = 1 minutes

* under Ubuntu 14.04 64-bit
** launched 46.0a1 (2016-01-12) + updated to latest 46.0a1 ⇒ time open = 0 minutes
** launched 46.0a1 (2016-01-12) + updated to latest 46.0a1 ⇒ time open = 1 minutes
Flags: needinfo?(alexandra.lucinet)
> unfortunately, I couldn't find any repack builds via ftp. If anyone
> could point me to the correct link, it would be greatly appreciated!

Alexandra, maybe you could use the partner builds from fx40 [1] and update it to fx43.0.4. When you're initially updating fx40 to fx43.0.1 , even though xpinstall.signatures.required;false, the Yahoo Toolbar will be disabled and xpinstall.signatures.required will be set to true once you've updated to fx 43.0.1. You can set xpinstall.signatures.required back to false and then continue updating to fx 43.0.4 which will re-enable the yahoo toolbar.

I'm not sure if the toolbar matters for this particular issue though. I was using the yahoo-en-ca build.

[1] https://archive.mozilla.org/pub/firefox/candidates/40.0-candidates/build5/partner-repacks/
Flags: needinfo?(alexandra.lucinet)
Thanks, Kamil!

After applying the first update - from 40.0 to 43.0.1 - the time open value resets to 0 minutes with every 40.0 build (normal one and partner repack - tried with bing, yahoo en-US and aol-de), under Windows 7 64-bit. The time open has the correct value after applying the 2nd update: from 43.0.1 to 43.0.4 and even to 44.0 (on release-localtest update channel). Alessio, maybe you could give some input? Thanks! :)
Flags: needinfo?(alexandra.lucinet)
Flags: needinfo?(alessio.placitelli)
From 42 (and for some users, 41), I think "time open" is computed using Telemetry data rather than FHR, so there could be a discontinuity from 40 to 41/42.

If the problem is no longer there going from 42 to 43 and 44, then I think it's fine.

Georg, since you worked on FHR-jelly, could we expect a change in the "time open" going from 40 to the UT-only Releases (42+)? If so, is it ok to close this bug?
Flags: needinfo?(alessio.placitelli) → needinfo?(gfritzsche)
Yes, that sounds fine to me, thanks.

Updating from Fx40 to Fx43 is expected to reset the "time open" measurement as we switched the sources it is computed from.
Updating from there to Fx43+ versions should have the proper "time open" behavior.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(gfritzsche)
Resolution: --- → WORKSFORME
Product: Firefox Health Report → Firefox Health Report Graveyard
You need to log in before you can comment on or make changes to this bug.