[Settings] Data connection turn off automatically after booting with low battery

RESOLVED FIXED in 1.1 QE2 (6jun)

Status

P2
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: leo.bugzilla.gaia, Assigned: rudyl)

Tracking

unspecified
1.1 QE2 (6jun)
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 fixed)

Details

(Whiteboard: [TD-24243] [LOE:S], URL)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
1. Title : Data connection turn off automatically after booting out of batter
2. Precondition : Data connection turn on and low battery
3. Tester's Action : let it be until out of battery
4. Detailed Symptom : After reboot, go to data connection menu. Data connection turn off
5. Expected : Data connection keep the status as on
6. Reproducibility: Y
   - Frequency Rate : 100%
7.Gaia Master/v1-train : No
8. Version Info
Gaia : 5cbb19e4bb78a7ad879fbe4b9a841e1c35714f5c
Gecko : e4a677c13bf35253fea99e6b85df1c707038d119
Mozilla build ID : 20130421070203

Comment 1

5 years ago
Is this scenario the origianl design?
Flags: needinfo?(shianyow)

Updated

5 years ago
Whiteboard: [TD-24243]
Target Milestone: --- → 1.1 QE2

Comment 2

5 years ago
(In reply to Ken Chang from comment #1)
> Is this scenario the origianl design?

No, it's not expected behavior.
Flags: needinfo?(shianyow)

Comment 3

5 years ago
I suspect it could be settings broken, and goes back to factory default value.
Are other settings normal when out of battery?
Flags: needinfo?(leo.bugzilla.gaia)
(Reporter)

Updated

5 years ago
Priority: -- → P2

Comment 4

5 years ago
(In reply to Shian-Yow Wu from comment #3)
> I suspect it could be settings broken, and goes back to factory default
> value.
> Are other settings normal when out of battery?

Other settings doesn't change when out of battery.
Sometimes it works well.
Flags: needinfo?(leo.bugzilla.gaia)
Summary: [Settings] Data connection turn off automatically after booting out of batter → [Settings] Data connection turn off automatically after booting with low battery
Just to clarify: the cellular radio is ON while data is OFF?

Comment 6

5 years ago
(In reply to Mike Habicher [:mikeh] from comment #5)
> Just to clarify: the cellular radio is ON while data is OFF?

The cellular radio is connected and only data is off.

Comment 7

5 years ago
(In reply to hyuna.cho from comment #6)
> (In reply to Mike Habicher [:mikeh] from comment #5)
> > Just to clarify: the cellular radio is ON while data is OFF?
> 
> The cellular radio is connected and only data is off.

Can you please provide a log?

Comment 8

5 years ago
(In reply to Shian-Yow Wu from comment #3)
> I suspect it could be settings broken, and goes back to factory default
> value.
> Are other settings normal when out of battery?

I checked all setting values when load Setting app.
Some values are changed like the below.
 geolocation.enabled
 geolocation.suspended
 powersave.enabled
 ril.data.enabled
 time.nitz.available

'powersave.enabled' value is changed from false to true. so 'ril.data.enable' also change from true to false.

I will attach a log soon

Updated

5 years ago
blocking-b2g: --- → leo+
What's the value in Settings App -> Battery -> Power save mode -> Turn on automatically option???

If it is not "never", that's correct to turn on powersave.enable and turn off the following settings:

  wifi.enabled
  ril.data.enabled
  bluetooth.enabled
  geolocation.enabled
Flags: needinfo?(hyuna.cho82)
Assignee: nobody → johu

Comment 10

5 years ago
(In reply to John Hu [:johnhu] from comment #9)
> What's the value in Settings App -> Battery -> Power save mode -> Turn on
> automatically option???
> 
> If it is not "never", that's correct to turn on powersave.enable and turn
> off the following settings:
> 
>   wifi.enabled
>   ril.data.enabled
>   bluetooth.enabled
>   geolocation.enabled

The default values are same with the follow
 powersave.enabled : false
 powersave.threshold : 0

After booting with low battery,
 powersave.enabled : true
 powersave.threshold : 0
Flags: needinfo?(hyuna.cho82)
I need to focus on another bug about email.
Assignee: johu → nobody
(Reporter)

Comment 12

5 years ago
Created attachment 751557 [details]
ADB_log

It's adb log file.
Assignee: nobody → rlu
Do we have everything we need for the investigation here? Any ETA for a patch?
Yes.
Will provide a patch today.

Thanks.
Whiteboard: [TD-24243] → [TD-24243] [LOE:S]
Created attachment 753741 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/9985

Pointer to Github pull-request
Comment on attachment 753741 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/9985

I think this is because the ambiguity of the threshold value, it is "0" originally, and I thought it won't reach that since we would power off the phone when the battery level < 2%.

And now I changed it to -1 for safety.

Hi Alive,

Please help review this simple patch.
Thanks.
Attachment #753741 - Flags: review?(alive)
Comment on attachment 753741 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/9985

I miss this...makes sense.
Attachment #753741 - Flags: review?(alive) → review+
Gaia master,
https://github.com/mozilla-b2g/gaia/commit/f2930cf440e0c8c21b48f7b0b01fac48b941e3fc


--
Alive, thanks.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-b2g18: --- → affected
status-b2g18-v1.0.1: --- → ?
Resolution: --- → FIXED
If you want this considered for 1.01, then you'll need a tef+. Although I don't think I would block on this for 1.01 at this point.
status-b2g18-v1.0.1: ? → ---
Uplifted f2930cf440e0c8c21b48f7b0b01fac48b941e3fc to:
v1-train: 055c80563dae10f75e6e970cbafcae2949f8a0f2
status-b2g18: affected → fixed

Updated

5 years ago
Flags: in-moztrap?

Updated

5 years ago
Flags: in-moztrap? → in-moztrap+
QA Contact: amiller

Updated

5 years ago
status-firefox26: --- → affected
Whiteboard: [TD-24243] [LOE:S] → [TD-24243] [LOE:S] burirun1

Comment 21

5 years ago
Wrongly added flag and whiteboard, looks like the build checked on just is having data connection issue not pertaining to low battery.
status-firefox26: affected → ---
Whiteboard: [TD-24243] [LOE:S] burirun1 → [TD-24243] [LOE:S]
You need to log in before you can comment on or make changes to this bug.