FrameInner(iframe) didn't set max-element-size!

VERIFIED WORKSFORME

Status

()

Core
Layout
P3
normal
VERIFIED WORKSFORME
19 years ago
19 years ago

People

(Reporter: Akkana Peck, Assigned: Nisheeth Ranjan)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Starting up the editor (apprunner -edit) on linux or windows, I always get a
slew of messages to stdout:

nsContainerFrame: FrameInner(iframe)(1)@0x82af3c8 didn't set max-element-size!
nsContainerFrame: FrameInner(iframe)(1)@0x82af3c8 didn't set max-element-size!
Note: verifyreflow is disabled
nsContainerFrame: FrameInner(iframe)(1)@0x82af3c8 didn't set max-element-size!
nsContainerFrame: FrameInner(iframe)(1)@0x82af3c8 didn't set max-element-size!
nsContainerFrame: FrameInner(iframe)(1)@0x82af3c8 didn't set max-element-size!
nsContainerFrame: FrameInner(iframe)(1)@0x82af3c8 didn't set max-element-size!
nsContainerFrame: FrameInner(iframe)(1)@0x82af3c8 didn't set max-element-size!
nsContainerFrame: FrameInner(iframe)(1)@0x82af3c8 didn't set max-element-size!
[ ... ]
nsContainerFrame: FrameInner(iframe)(1)@0x82af3c8 didn't set max-element-size!

Steve says:
> this is a bug in iframe.  it would occur if the iframe were in
> a table cell's contents.

Updated

19 years ago
Assignee: rickg → nisheeth

Comment 1

19 years ago
An easy kill of this layout bug for you.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 2

19 years ago
I tried this on a July 9th NT debug build and did not see these messages.  I'm
updating to the tip to see if this problem still exists...
(Assignee)

Updated

19 years ago
Whiteboard: Mark worksforme?
(Assignee)

Comment 3

19 years ago
We no longer get these error messages in the tip debug build on NT.  I checked
that the printf that outputs these messages is enabled for the debug build.

Steve and Akkana, if you are ok with it, I'm going to mark this bug worksforme.
Also ccing Eric Pollmann and Chris Karnaze to see if they checked in a fix that
could have fixed this problem.
(Reporter)

Comment 4

19 years ago
I agree, I no longer see these messages.  Someone obviously checked in a fix
which cures the problem.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 5

19 years ago
Marking bug worksforme.
(Assignee)

Updated

19 years ago
Whiteboard: Mark worksforme?

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 6

19 years ago
Since I can't reproduce either, marking as verified works for me.
You need to log in before you can comment on or make changes to this bug.