Last Comment Bug 871514 - Replace "click" with "touch" on About:firefox update button
: Replace "click" with "touch" on About:firefox update button
Status: RESOLVED FIXED
[mentor=kats][good first bug]
:
Product: Firefox for Android
Classification: Client Software
Component: Theme and Visual Design (show other bugs)
: unspecified
: All Android
: -- normal (vote)
: Firefox 24
Assigned To: Shane Tully (:stully:
:
: Anthony Lam (:antlam)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-13 06:02 PDT by Ian Barlow (:ibarlow)
Modified: 2016-07-29 14:33 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
change strings as described in comments (1.78 KB, patch)
2013-05-22 13:58 PDT, Shane Tully (:stully:
bugmail: review-
Details | Diff | Splinter Review
02 Remove "click" from update strings to accomodate touch devices (3.16 KB, patch)
2013-05-22 15:27 PDT, Shane Tully (:stully:
bugmail: review+
Details | Diff | Splinter Review

Description Ian Barlow (:ibarlow) 2013-05-13 06:02:42 PDT
When tapping the "check for updates button", the string that comes back reads

"Update available; click to download"
or
"Update available; click to install"

We shouldn't be using the word "click" on Android, let's change it to "tap".
Comment 1 Aaron Train [:aaronmt] 2013-05-13 06:37:53 PDT
This was added in bug 827347 because there is no concept of tapping on Ouya.
Comment 2 Ian Barlow (:ibarlow) 2013-05-13 06:38:50 PDT
Ah, I was wondering what brought about the change... Can we special case the Ouya builds, then so that they don't affect devices with touch screens?
Comment 3 Ian Barlow (:ibarlow) 2013-05-13 06:53:30 PDT
Updating title -- for consistency with our updater we should use touch, not tap.
Comment 4 Mark Finkle (:mfinkle) (use needinfo?) 2013-05-13 10:39:11 PDT
I want to give Kats a chance to respond since he championed the change. I do think Ouya has a touchpad on the controller, so "touch" or "tap" might not be as foreign to those users.
Comment 5 Kartikaya Gupta (email:kats@mozilla.com) 2013-05-21 13:28:27 PDT
While the Ouya controller does have a touchpad, it is used to control a mouse cursor that appears on the screen, so I think using "click" is the most appropriate for that scenario. Using "tap" might be ok there too, but "touch" doesn't feel right for that scenario. If we absolutely want to use "touch" or "tap" for touch-enabled devices I'm not opposed to special-casing this.
Comment 6 Ian Barlow (:ibarlow) 2013-05-21 13:30:32 PDT
Hm, or we could just change the string everywhere to read "Download update" when one is available
Comment 7 Kartikaya Gupta (email:kats@mozilla.com) 2013-05-21 15:11:10 PDT
That sounds good to me. There's another message that shows up after the update is downloaded that says "Updated downloaded; click to install" - I assume we should change that to "Install update" as well.
Comment 8 Kartikaya Gupta (email:kats@mozilla.com) 2013-05-21 15:12:34 PDT
Trivial string changes make for good first bugs :) The strings are located in mobile/android/locales/en-US/chrome/about.dtd.
Comment 9 alexchan7432 2013-05-21 17:19:14 PDT
Hi,
I'd like to get involved with FireFox Mobile, figure this would be a good first bug.  Mind if I assign this one to myself?
Comment 10 Mark Finkle (:mfinkle) (use needinfo?) 2013-05-22 05:55:21 PDT
(In reply to alexchan7432 from comment #9)
> Hi,
> I'd like to get involved with FireFox Mobile, figure this would be a good
> first bug.  Mind if I assign this one to myself?

Go ahead. For some information on building Firefox on Android, see:
https://wiki.mozilla.org/Mobile/Fennec/Android

For realtime chatting with other developers, visit #mobile on Mozilla's IRC server:
http://irc.mozilla.org
Comment 11 Shane Tully (:stully: 2013-05-22 13:58:24 PDT
Created attachment 752955 [details] [diff] [review]
change strings as described in comments

Changed updates available and updates downloaded strings as described in comments.
Comment 12 Kartikaya Gupta (email:kats@mozilla.com) 2013-05-22 14:53:42 PDT
Comment on attachment 752955 [details] [diff] [review]
change strings as described in comments

Review of attachment 752955 [details] [diff] [review]:
-----------------------------------------------------------------

After double-checking the string change procedure [1] (I haven't had to do this very often) it looks like we'll have to update the entity names as well. So for example you can change aboutPage.checkForUpdates.available to aboutPage.checkForUpdates.available2 in the dtd file and update the references to it in about.xhtml as well.

Also please make sure your patch includes a commit message as per [2]

[1] https://developer.mozilla.org/en-US/docs/Making_String_Changes
[2] https://developer.mozilla.org/en-US/docs/Mercurial_FAQ#How_can_I_generate_a_patch_for_somebody_else_to_check-in_for_me.3F
Comment 13 Shane Tully (:stully: 2013-05-22 15:27:05 PDT
Created attachment 752996 [details] [diff] [review]
02 Remove "click" from update strings to accomodate touch devices

Change string entity names and reflect changes in about.xhtml (and added commit message; sorry!)
Comment 14 Kartikaya Gupta (email:kats@mozilla.com) 2013-05-23 06:20:08 PDT
Comment on attachment 752996 [details] [diff] [review]
02 Remove "click" from update strings to accomodate touch devices

Review of attachment 752996 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, thanks!
Comment 15 Ryan VanderMeulen [:RyanVM] 2013-05-29 17:40:00 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/48b38e667074
Comment 16 Ryan VanderMeulen [:RyanVM] 2013-05-30 09:10:13 PDT
https://hg.mozilla.org/mozilla-central/rev/48b38e667074

Note You need to log in before you can comment on or make changes to this bug.