Last url from privatebrowsing leaks the next time firefox i started

RESOLVED DUPLICATE of bug 865005

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 865005
5 years ago
a year ago

People

(Reporter: hasse-mozillabug, Unassigned)

Tracking

20 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130409194949

Steps to reproduce:

Started private browsing and loaded an url


Actual results:

The next time I am starting firefox it will shortly show the url from last times private browsing session


Expected results:

It should not leak stuff from private browsing
Can you further detail your steps to reproduce? Also can you indicate which version of Firefox and which device and OS version you are testing with?

> The next time I am starting firefox it will shortly show the url from last times private browsing session

What do you mean by shortly and where are you seeing that?
Flags: needinfo?(hasse-mozillabug)
(Reporter)

Comment 2

5 years ago
Actually. Right now I cannot reproduce it and anyway thinking of it it may not be that bad. Having I private tab open and then using other programs on the phone when another program then sends an intent with an url it seems that firefox sometimes will show the private tab very shortly before loading url send to it via the intent

But I have a hard time reproducing this right now. Maybe we can just close this as I can just close the private tab everytime (then I don't think I will show up before loading another normal tab)

I am using Firefox for android 20.0.1 on a Nexus 4 with stock rom/kernel 4.2.2
Flags: needinfo?(hasse-mozillabug)
Sounds like this is happening when Firefox is killed in the background, when other apps are running and Android needs memory. The correct behavior in that case is that the private tab is never closed at all, and it is restored when you reopen Firefox. It sounds like what you're seeing is the tab is restored, but the selected tab quickly changes to another tab during startup (one of the symptoms of bug 865005).

When this happens, I assume that the private tab is still open if you look at your list of private tabs?
Duping with bug 865005 since the symptoms here sound like the same issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 865005
(Reporter)

Comment 5

5 years ago
Yes exactly. I sounds like the same issue
You need to log in before you can comment on or make changes to this bug.