If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

the MP doesn't make re authentication when is changing the Sim card

RESOLVED INVALID

Status

Marketplace
Payments/Refunds
--
major
RESOLVED INVALID
5 years ago
4 years ago

People

(Reporter: eder, Unassigned)

Tracking

x86
Windows 7
Points:
---

Details

(Reporter)

Description

5 years ago
steps to reproduce:

1. Open Marketplace via WiFi connection
2. Log out of MP
3. Insert a different SIM into the device and Login to MP
4. find the app paid and purchase 
5. The phone number never asked when was the change of Sim Card


expected behavior:

in Persona login and user is asked to confirm their mobile phone number when  changed the Sim card 


observed behavior:

The phone number never asked when was the change of Sim Card, just during buying this information is necessary.
If you're just talking about ownership of apps, that is determined by persona, not SIM, which would make this bug invalid.

If you're talking about being billed, that's true, but that's bug 871591.

I'm going to close this, let me know if I've misunderstood.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID

Comment 2

5 years ago
After every logout, the user needs to reauthenticate since we delete the Bango cookie. I wonder why the user is not being asked to authenticate at step #3

Comment 3

4 years ago
I'm having the same problem in Colombia. The re-authentication is never required after SIM card changing.

Comment 4

4 years ago
Same behavior changing for a different carrier SIM and the purchase is completed.
You need to log in before you can comment on or make changes to this bug.