Progress updating is intermittent downloading large newsgroups

RESOLVED WORKSFORME

Status

MailNews Core
Networking: NNTP
--
minor
RESOLVED WORKSFORME
17 years ago
4 years ago

People

(Reporter: stephend@netscape.com (gone - use stephen.donner@gmail.com instead), Unassigned)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Build ID:  2001-06-20-15, RedHat 7.1 (out of the box setup)

Summary: We're not getting good progress meter/throbber updating when
downloading large newsgroups.

Steps to Reproduce:

1.  Create a new account with at least 50,000 headers in a single newsgroup. 
(In my case news://news.netscape.com/mcom.beta.feedback.browser did the trick)
2.  Click on the newsgroup, and choose "Download All Headers".

Expected Results:

While expecting this to take a while due to the large number of headers, there
should always be throbber updating and progress meter updating occuring.

Actual Results:

I saw the throbber only update once every 3-5 minutes, and Moz stopped updating
the "Downloading X of 67231 headers" at # 59720, after which the program hung. 
Also, the progress meter was only updating every 20,000 newsgroups or so.
I just tried this on my Mac OS 9.1 build 2001-06-21-08, and although the
throbber and status bar synchronization could be better, it finished and
returned the app to a responsive state once it was done downloading the headers.
Summary: No progress updating when downloading large newsgroups → Progress updating freezes downloading large newsgroups
... and my linux box just finished now, too.  Even with 4.x, this takes a
considerable amount of time, but the real bug here is that we're not properly
updating progress.   Since I'm not freezing with this build, changing the scope
of this back to the progress updating.
Summary: Progress updating freezes downloading large newsgroups → Progress updating is intermittent downloading large newsgroups
Side note: this newsgroup takes 41 minutes to download on my Win2K machine using
4.x.  Your mileage may vary.
I'm seeing this too.  not sure when it regressed.
OS: Linux → All
Hardware: PC → All
I'm downloading older trunks builds, will attempt to track this down to a batch
of checkins.
The earliest ftp.mozilla.org has builds is the 10th.  Checking bonsai now.
Seth, do you think this bug is a DUP of your bug 60822?
Keywords: nsBranch

Updated

17 years ago
Blocks: 99230

Comment 8

17 years ago
cleaning up nsbranch keywords. 
Keywords: nsbranch → nsbranch-

Updated

17 years ago
No longer blocks: 99230

Updated

16 years ago
Blocks: 63759

Updated

16 years ago
Blocks: 107067

Updated

16 years ago
Keywords: nsbranch-

Comment 9

16 years ago
Stephend, AFAICS bug 60822 is for downloading subscribable newsgroups, this bug
is for downloading headers from a single newsgroup.
Hwaara, indeed you are correct, thanks for the clarification.
Product: MailNews → Core
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
Filter on "Nobody_NScomTLD_20080620"
QA Contact: stephend → networking.news
(Assignee)

Updated

9 years ago
Product: Core → MailNews Core

Updated

8 years ago
Severity: major → minor
Trying with rec.games.pinball on a server with ~1mo retention time (total articles 23K or so). It updated about once every 200 headers (noticeable lag, but only a few hundred ms), and the progress bar and throbber kept on spinning. Not stellar, but you can tell it's still running.

--> WFM.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.