Closed Bug 872050 Opened 7 years ago Closed 7 years ago

remove /data/local/xpcb from tegras in the cleanup step

Categories

(Release Engineering :: General, defect, P1)

ARM
Android
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jmaher, Assigned: jmaher)

References

Details

Attachments

(1 file, 2 obsolete files)

I have found that we store many files in /data/local/xpcb even after we have uninstalled fennec from the device:

adb shell ls -l /data/local/xpcb
-rwxrwxrwx app_31   app_31              21552 2013-05-13 16:16 libomxplugingb.so
-rwxrwxrwx app_31   app_31              22268 2013-05-13 16:16 libomxpluginjb-htc.so
-rwxrwxrwx app_31   app_31              21556 2013-05-13 16:16 libomxplugingb235.so
-rwxrwxrwx app_31   app_31              21575 2013-05-13 16:16 libomxpluginfroyo.so
-rwxrwxrwx app_31   app_31           51491554 2013-05-13 16:15 libxul.so
-rwxrwxrwx app_31   app_31              22172 2013-05-13 16:16 libomxplugin.so
-rwxrwxrwx app_31   app_31            2092625 2013-05-13 16:15 libnss3.so
-rwxrwxrwx app_31   app_31              21580 2013-05-13 16:16 libomxpluginhc.so
-rwxrwxrwx app_31   app_31             498708 2013-05-13 16:16 libnssckbi.so
-rwxrwxrwx app_31   app_31              13327 2013-05-13 16:16 libplugin-container.so
-rwxrwxrwx app_31   app_31             506015 2013-05-13 16:16 libmozglue.so
-rwxrwxrwx app_31   app_31                495 2013-05-13 16:20 xpcw
drwxrwxrwx app_31   app_31                      2013-04-08 12:09 defaults
-rwxrwxrwx app_31   app_31           29047713 2013-05-13 16:15 fennec-24.0a1.en-US.android-arm.apk
-rwxrwxrwx app_31   app_31              22418 2013-05-13 16:16 libomxpluginsony.so
-rwxrwxrwx app_31   app_31           25186732 2013-05-13 15:16 fennec-24.0a1.en-US.android-arm-armv6.apk
-rwxrwxrwx app_31   app_31             731229 2013-05-13 16:15 xpcshell
-rwxrwxrwx app_31   app_31           28945697 2013-05-10 06:18 fennec-23.0a1.en-US.android-arm.apk
-rwxrwxrwx app_31   app_31             287001 2013-05-13 16:16 libfreebl3.so
-rwxrwxrwx app_31   app_31             217962 2013-05-13 16:16 libsoftokn3.so
-rwxrwxrwx app_31   app_31              13773 2013-05-13 16:15 libmozalloc.so
-rwxrwxrwx app_31   app_31           25183797 2013-05-13 05:58 fennec-23.0a1.en-US.android-arm-armv6.apk

I have verified we can do 'rmdr /data/local/xpcb' and reboot the device successfully.  This should help us reduce errors related to out of space which we see periodically.
Attached patch help cleanup the tegras (1.0) (obsolete) — Splinter Review
we do not have this directory on pandas, but this command will just issue an agent warning and continue on.
Assignee: nobody → jmaher
Status: NEW → ASSIGNED
Attachment #749306 - Flags: review?(bugspam.Callek)
Duplicate of this bug: 872051
Any clue how/why these are ending up there, we should be writing to the sdcard /mnt/sdcard/tests directory in all cases. (Even if tests are broken we can still fix this, but I'd rather fix tests)

Also are we *sure* everything in here (and the dir) is ok to delete [aka: created merely by our tests]?
This directory and its contents are created by the Android xpcshell tests. xpcshell itself is an executable and cannot be installed on /mnt/sdcard. I think the libraries have the same requirement; the apk is there more for convenience. Bug 827509 is open for trying to reduce /data requirements, but I don't think much can be done. 

Regular cleanup of this directory is essential and it is definitely OK to delete.
ha, and I thought it was a system binary thing!  now it all makes sense:)
Comment on attachment 749306 [details] [diff] [review]
help cleanup the tegras (1.0)

Is there a reason we're not using dm.removeDir() ?
http://mxr.mozilla.org/build/source/tools/sut_tools/mozdevice/devicemanagerSUT.py#563

And then a check to verify that it is indeed gone after?
http://mxr.mozilla.org/build/source/tools/sut_tools/mozdevice/devicemanagerSUT.py#481
Attachment #749306 - Flags: review?(bugspam.Callek) → review-
The length of time before we have zero usable tegras should be equal to the length of time until every tegra has done one or two 24.0a1 xpcshell runs, i.e. not long.
Severity: normal → blocker
Priority: -- → P1
Stepping in on request, to try to get this moving tonight...
Attachment #749306 - Attachment is obsolete: true
Attachment #749562 - Flags: review?(bugspam.Callek)
Comment on attachment 749562 [details] [diff] [review]
cleanup /data/local/xpcb using dm.removeDir

nit in each setFlag and log.info here can you pass xpcbDir as well, so we can know what dir it couldn't remove.

nit: can you add a comment something like "# xpcshell stores binaries here"
Attachment #749562 - Flags: review?(bugspam.Callek) → review+
Updated for nits -- worth checking over again.
Attachment #749562 - Attachment is obsolete: true
Attachment #749570 - Flags: review?(bugspam.Callek)
Attachment #749570 - Flags: review?(bugspam.Callek) → review+
In production (updated foopies)
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
That caused a failure in cleanup as seen here: https://tbpl.mozilla.org/php/getParsedLog.php?id=22963737&tree=Mozilla-Inbound&full=1#error0

There seems to be a problem with deleting the /data/local/xpcb directory itself.

Follow-up to remove error checking: https://hg.mozilla.org/build/tools/rev/fb58093bab4b
Blocks: 861745
Product: mozilla.org → Release Engineering
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.